Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Albert (http://www.jeepgarage.org/f203/albert-24682.html)

bajan 06-20-2011 01:37 PM

Albert
 
I installed a new pcm in 4.7 cheroke and it worked fine for 3 weeks, then it gave a no start condition on two occasions finally not starting again.
Pcm not communicating on bus and Skim is showing warning light with a line through it.

I had it scanned and the tool is not communicating with the pcm
the skim is showing SKIS failure and the bus is showing 2 open circuits

i need your help

cheapjeep 06-20-2011 01:49 PM

Re: Albert
 
I'd check all o your pcm connection first.One might have a bad connection.Also I'm sure you already know that you have to have the pcm flashed or your key.

Frango100 06-20-2011 05:23 PM

Re: Albert
 
For which reason did you have to change the PCM?
The PCM most probably was flashed with the SKIS info, otherwise it would have never worked from the start.
As cheapjeep mentioned, remove/check/connect all PCM connectors and pay special attention that no connector pins are pushed back.

2005JGC 06-22-2011 02:38 AM

Move your coolant reservoir and get to your pcm connectors. I like to put my multi meter on my 5 volt supply on the easily assessable map sensor. Key on I am guessing you will have nothing. Now one at a time grab the pcm connectors and jiggle... Just a hunch but one of them I'm guessing you will see your 5v come to life at which point your rig will start. I have had a couple recently where the connector is clean with no corrosion and a pcm cured the concern... Both with dieout issues no communication and skim codes. My best guess is apoor solder in the pcm.

Interestingly enough they were 4.7 wj's
Sent from my SCH-I500 using Tapatalk

bacernate 06-23-2011 12:00 AM

Re: Albert
 
Haven't seen this on a wj but replaced alot of pcm's on dakotas and durangos. They are dropping like flies. A shorted cam or crank sensor can also take the network down. Unplug them one at a time and see if the pcm comes to life. I assume your check engine light is also out koeo when it won't start, that's a dead give away the pcm is down.


All times are GMT -5. The time now is 07:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community