Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   A/C Compressor not engaging! (http://www.jeepgarage.org/f77/a-c-compressor-not-engaging-24779.html)

cobrakillerta 06-22-2011 10:37 AM

A/C Compressor not engaging!
 
I have an '06 WK Overland with the 5.7L HEMI...
Over this past winter I had to replace my radiator. While cruising down the highway the car infront of me kicked up a large truck tire thread which wrapped up under my bumper and pierced the lower plastic portion of my radiator. In the process of replacing my radiator in the mioddle of winter I accidently kinked/pierced one of the aluminum A/C lines. It's the 'liquid line' which is a smaller aluminum line which runs from the accumulator just below the large low-pressure hose and back to the firewall.

I just replaced the line and attempted to recharge the system from the low-pressure port. I couldn't accurately check the system pressure as the compressor was not engaging (am I correct that the compressor needs to be engaged to accurately check the pressure?), but I did get just about the recommended amount of R134 into the system (approx. 34oz.). I believe the compressor did engage while I first started recharging the system as I could hear it squeel. Since then and after recharging the system I'm still not getting any cold air as the compressor is not engaging. I can easily turn the compressor by hand so it doesn't seem to be seized. I removed the A/C clutch relay and tried using a jumper wire to engage the clutch/compressor but with the 5 prongs on the relay I wasnt sure which ones to jump together. I tried different combinations with a jumper wire but nothing worked and the compressor clutch is still not engaging.

Anyone have any ideas? I'm stooped

Frango100 06-23-2011 06:39 PM

Re: A/C Compressor not engaging!
 
You did visually check that the compressor didn't engage?
You will have to connect 30 to 87 on the compressor clutch relay to have power to the clutch solenoid. Did you check the fuses first to be sure that none is blown? If you randomly tried to jumper the pins, you can have blown a fuse.
The compressor clutch relay is switched by the PCM and also has a separate fuse.

jeepnjeep 06-23-2011 10:14 PM

Re: A/C Compressor not engaging!
 
You also opened to system to the atmosphere and contaminated it with moisture in the air. It will need to be evacuated, pulled into a vacuum and recharged properly. Save yourself a lot of headaches and bring it to someone qualified.

soontobesrt 06-28-2011 09:44 PM

Re: A/C Compressor not engaging!
 
Dont know if this is relevant for the WJ but on my WK I had an issue similar where it wouldnt engage and it turned out to be just the control board inside was not plugged in all the way. Somehow it came loose and none of my HVAC worked at all. Does the fan blow at all? Hope you get it sorted!

Marlin 06-28-2011 10:14 PM

Re: A/C Compressor not engaging!
 
An aircon compressor WON'T engage if the pressure isn't Juuuust right. The WK is especially finikky with pressures, as I've found out recently. Too much pressure, won't engage, too little pressure, same issue.


All times are GMT -5. The time now is 10:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community