Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   99 4.0 running hot (http://www.jeepgarage.org/f196/99-4-0-running-hot-24791.html)

99PlatinumWJ 06-22-2011 05:04 PM

99 4.0 running hot
 
hello all,

first off i have a 1999 gc laredo 4.0 selec-trac. my jeep has been running hot while idling, usually with the a/c on. i just read a bunch of threads about this and most of the time its the fan relay under the passenger headlight. i replaced it last year with one from a wreaked wj (it was free so why not try it) as mine didnt work anyway when i bought my jeep.
this year i replaced the electric fan motor (in know it works i tested it off the battery before i installed it) and the fan still doesnt turn on even when it passes 210* :(
i also checked the fuse under the hood and it was not blown.
so should i buy a brand new fan relay and replace it? i think there are only 3 main parts that would effect the fan not working(the fan motor, fuse and relay) correct? with the first 2 working it should be the relay right? anything else i should look into?
please help asap, im worried to drive a lot of the time because i dont want to get caught in traffic and overheat...
thanks in advance for the help and suggestions, i appreciate it!

cheapjeep 06-22-2011 05:41 PM

Re: 99 4.0 running hot
 
Mike on our 99 4.0 the fan kicks on with the a/c so it should be running as soon as you hit the air no mater what temp the engine is. Even so if you climb a big enough hill with the a/c on it will get warm. Just the nature of the beast with a 4.0 I guess. Still your fan should kick on with the a/c. I'd say probably the relay again.

99PlatinumWJ 06-22-2011 06:01 PM

Re: 99 4.0 running hot
 
Thanks dave,
I know they are known to run warm, but like I said even with the a/c on it doesn't kick on. I think I'm going to replace it and hopefully its one less problem I need to worry about lol

mon_21 06-23-2011 12:30 PM

Re: 99 4.0 running hot
 
I'd say go get a brand new relay. But I will also check for the fan, mine froze up one time and I had to remove it and hotwire it to the batt for a jump. Im actually due for a new fan motor....

99PlatinumWJ 06-23-2011 01:38 PM

Re: 99 4.0 running hot
 
Thanks, I'm going to get a new relay soon then!
Oh my fan motor is brand new and I tested it before installing it.
Thanks for all the help fellow jeepers :)

violant00 06-23-2011 03:21 PM

Re: 99 4.0 running hot
 
this just happend to me... it went all the way up to 260! when i checked under the hood the resevoir for the coolant was WAY passed the filled point turned it on and off and drove with the ac off and it went back to normal.

99PlatinumWJ 06-23-2011 04:00 PM

Re: 99 4.0 running hot
 
Oh my gosh 260!?! Hopefully nothing was effected by that and your jeep is ok..

violant00 06-23-2011 08:26 PM

Re: 99 4.0 running hot
 
i agree man i really hope nothing happend i hope its not my water pump going out :/

Quote:

Originally Posted by MichaelNawrocki (Post 436480)
Oh my gosh 260!?! Hopefully nothing was effected by that and your jeep is ok..


99PlatinumWJ 06-23-2011 08:54 PM

Re: 99 4.0 running hot
 
Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol

violant00 06-23-2011 11:13 PM

Re: 99 4.0 running hot
 
i think i do... but im not 100% sure i opened my radiator tonight and didn't see the antifreeze move or flow at all... is this normal? im not familiar with reservoir/ radiator type cooling systems so im not sure if i should see the coolant flowing


Quote:

Originally Posted by MichaelNawrocki (Post 436617)
Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol


Sir Sam 06-23-2011 11:22 PM

Re: 99 4.0 running hot
 
Quote:

Originally Posted by MichaelNawrocki (Post 436617)
Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol

IMO the 4L has one of the easiest to replace water pumps of any vehicle I have ever worked on.

You should see how much trouble it is to do on my KJ.

Frango100 06-24-2011 10:14 AM

Re: 99 4.0 running hot
 
As long as the thermostat is closed (engine cold), there will be no flow through the the radiator. But eventhough you would see some fluid moving, its still no indication that the pump is 100%.
When the temperature went that high, was the cooling fan running normally? If yes, then your problem could be the pump, but also the thermostat or even a partly clogged radiator.


All times are GMT -5. The time now is 12:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community