Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   K&N Air intake installed - but some problems! (http://www.jeepgarage.org/f196/k-and-n-air-intake-installed-but-some-problems-2503.html)

Andrew 09-04-2009 06:48 PM

K&N Air intake installed - but some problems!
 
Well, I got the K&N Cold Air Intake, the 57 Gen II.
For my 1999 Grand Cherokee Laredo.

Got it all installed right, clamped down good and tight.
It works great, but i notice side affects.

My RPMS go way too low after I rev the engine as hard as it can go.

I put my foot all the way down on the acceleration, and when the needles goes back down, it goes to 0 and slowly back to below 1.

It conked out once. This is only in Nuetral, which i know theres something wrong here.

It can't be the air intake.
Theres no leaks in the intake.

Must be something else. HELP, please! :(

UPDATE: VIDEO POST!
http://www.disneylandonline.com/videos/
Check out the Air Intake Video!

robpp 09-04-2009 09:24 PM

Re: K&N Air intake installed - but some problems!
 
i would look at all vacuum lines. a 99 you may have some worn or cracked ones.

I have K&N on my 4.0 since 1998 not one problem ever.

but it sounds like you have the v8.

either way, i doubt its the intake.

jeepnjeep 09-04-2009 09:27 PM

Re: K&N Air intake installed - but some problems!
 
You might have cracked or knocked loose a vacuum line like robpp said. Easy to do and not notice.

Andrew 09-05-2009 02:15 PM

Re: K&N Air intake installed - but some problems!
 
Well, wouldnt my Cruise Control not work if my Vacuum was torn?

Anyways,
I think you guys are right, good possibility that it could be the Vacuum.

Do you know where to check for those lines? Maybe I can see if theres any worn/tears/cracks. If so, easy to get repair? How much?

Thanks guys for the feedback, I know its not my air intake. But since I upgraded, it made things more noticeable on my jeep thats going bad.

Let me know if you know anyone who might know what the problem that could cause it!

Thanks! :)

mon_21 09-05-2009 05:26 PM

Re: K&N Air intake installed - but some problems!
 
check all the hoses in the vicinity and around the old stock one.....
( not the air filter box )

Andrew 09-05-2009 10:10 PM

Re: K&N Air intake installed - but some problems!
 
I can tell that my RPM gets low when I brake quickly from high accelerations. Stopping at a light. Postivie it's the vacuum?

Also, the needle on the rpm, at stop light, sure does move alot, more like a shake. It wont ever stay in one spot. Like its spazzed out.

I'll get it diagnoised at the shop next Friday.

---------- Post added at 11:10 PM ---------- Previous post was at 10:58 PM ----------

It's a V6 4.0L.
My Cruise Control works great, my OverDrive works good too!

Trying to figure out how its the vacuum.

Quote:

Originally Posted by robpp (Post 57336)
i would look at all vacuum lines. a 99 you may have
some worn or cracked ones.

I have K&N on my 4.0 since 1998 not one problem ever.

but it sounds like you have the v8.

either way, i doubt its the intake.


Martyp 09-06-2009 03:56 AM

Re: K&N Air intake installed - but some problems!
 
Yeah, must be a vac hose somewhere, if everything is tight on the intake.
Good thing is the hoses are cheap as chips, its just finding them...

Anyways, good luck and is this intake in preparation for the ram-air hood?!? :D

dreamer1213 09-06-2009 07:35 AM

Re: K&N Air intake installed - but some problems!
 
Thats sweet that you got an intake for the Jeep Andy...

You have the take all of the vacuum hoses off the stock intake...perhaps you just didn't hook on back up...

And remember...its an Inline 6, not a V6...LOL!!

Andrew 09-06-2009 10:44 AM

Re: K&N Air intake installed - but some problems!
 
Haha, well I never knew I had to call it a Inline 6. geeeeze!

I love my Air intake.
I get my Jet Chip Stage 2 in 2 weeks! That's my goal.

I kinda gotta stop spending money on my jeep because I have to get furniture and a queen set for when I move out. But I'm sneaking in the Jet Chip. hehe. Need more power for the inerstate. ha.

So it must be a small leak/crack somewhere. Because my cruise control still works.

Thanks guys!

Haha, Marty, I will get that hood sooner or later.

Martyp 09-06-2009 11:23 AM

Re: K&N Air intake installed - but some problems!
 
Lol, nice one Andy!

Hope you get it sorted easy enough and enjoy the chip!

By the way, I6 is the quicker way to type it, V6 is a different type of engine - but we know what ya mean anyway bro! :thumbsup:

Andrew 09-06-2009 09:13 PM

Re: K&N Air intake installed - but some problems!
 
So how much hp does the Jet Chip Stage 2 give the I6?

They say that eventually, the chip will no longer work, and everything will go back to normal. True?

Should I just get a programmer like "Super Chip"?

Dylans3960ccs 09-06-2009 09:31 PM

Re: K&N Air intake installed - but some problems!
 
Well mabey it's just me, but I think since the 4.0L has a fuel cut off instead of an electric rev limiter it may just be limiting the motor too much. So I think that if you rest the computer it might not do that any more. just my $.02


All times are GMT -5. The time now is 11:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community