Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   hid's problem (http://www.jeepgarage.org/f5/hids-problem-25160.html)

bmwdc24 06-30-2011 09:45 PM

hid's problem
 
i have hid's in my grand cherokee and i am having lots of problems with them. i wanted to see if anybody else had theys problems or if its the set i bought. i have already replaced one of the balises. when i turn them off they flicker. and some times when iturn them on only one will go on. sometimes one and then the other. and if the car is running i cant turn them off or they wont go back on unless i let the car rest for a little.

White Chocolate 06-30-2011 09:48 PM

Re: hid's problem
 
do you have a relay harness?? which brand is it?

DAVY27 06-30-2011 10:04 PM

Re: hid's problem
 
x2 on the relay!

05WK 06-30-2011 10:55 PM

Re: hid's problem
 
I had that problem before and it wasnt the relay harness, it was the ballist's. At that rate, one will soon give out, then the other will next. Best bet is to have the company send you new ones. Hopefully, still on warranty?

tri0829 06-30-2011 11:50 PM

Re: hid's problem
 
sounds like u need a relay harness to me

mhardine 07-01-2011 08:14 AM

Re: hid's problem
 
had the same prob. relay harness fixed it

05WK 07-01-2011 05:25 PM

Re: hid's problem
 
Agree on the relay harness too. Just re-read the post

White Chocolate 07-02-2011 12:29 AM

Re: hid's problem
 
So man, u gunna reply? Figure it out yet?

thex2 07-02-2011 12:57 AM

Re: hid's problem
 
as everybody else has mentioned, you need a relay harness. the reason they won't come back on after you turn them off is because your ballasts likely have an auto-shutoff for when they can't draw enough power. For whatever reason, the WK pumps 10.x volts to the low beams after they've been shut off and the vehicle is still running. continuing this behavior will continue destroying parts. it's very very bad to continue short powering your HIDs, so get that relay installed asap.

bmwdc24 07-03-2011 11:10 AM

Re: hid's problem
 
i dont have the relays. i just ordered them, thanks for all the help. i will check back when they come in and let you know how they worked out.

bmwdc24 07-11-2011 02:11 PM

Re: hid's problem
 
def worked! thanks!


All times are GMT -5. The time now is 01:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community