Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Help!!! (http://www.jeepgarage.org/f5/help-2524.html)

jeeppro 09-06-2009 07:28 PM

Help!!!
 
MY ENGINE LIGHTS ON AND ITS MY IAT SENSOR ANY CLUES:mad:

Marlin 09-06-2009 07:30 PM

Re: Help!!!
 
HAve you been working on the Jeep?

jeeppro 09-06-2009 07:31 PM

Re: Help!!!
 
No just put fastmans tb and airrams pwerwire

Frankie 09-06-2009 07:32 PM

Re: Help!!!
 
Didnt Sleepy say something about the TBs throwing codes?!

jeeppro 09-06-2009 07:32 PM

Re: Help!!!
 
I dont know

Frankie 09-06-2009 07:34 PM

Re: Help!!!
 
"""The Hemi TB is actuated electronically....on the other motors you see (3.7,4.0,5.2/5.9, 4.7, etc) they are operated using a cable connected to a gas pedal.

I have heard about the Hemi crowd getting funky performance when messing with the throttle body, mainly when the blade is moved around with the engine off. The last thing I want to do is screw up someone's ride. The throttle body sensors can be reset, that's probably what needs to be done upon installing."""

jeeppro 09-06-2009 07:35 PM

Re: Help!!!
 
OK

Frankie 09-06-2009 07:36 PM

Re: Help!!!
 
Hope that helps...

Scottina06 09-06-2009 07:38 PM

Re: Help!!!
 
make sure everything is plugged in correctly, remove your negative battery cable, depress your brake pedal and wait 10-15 minuted. reconnect the cable and you should be golden....

jeeppro 09-06-2009 07:38 PM

Re: Help!!!
 
Nice

Scottina06 09-06-2009 07:49 PM

Re: Help!!!
 
your iat sensor isnt plugged in correctly...check it and try what i said above

jeeppro 09-06-2009 07:49 PM

Re: Help!!!
 
thanks scott appreciate it


All times are GMT -5. The time now is 10:18 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community