Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Transmission problem? (http://www.jeepgarage.org/f5/transmission-problem-25580.html)

TB_Jeep 07-11-2011 10:15 PM

Transmission problem?
 
I'm new to this site & I'm having a problem w/ my Jeep. Hope you can help! :)
I have a 06 JGC, Laredo. It has about 81k miles on it now. I purchased it back in April. Shortly after, I noticed the downshift was a little rough sometimes.
About a month ago, while trying to merge onto the freeway, I needed to speed up to merge.. well, I stepped on the gas and then realized that I wouldnt be able to speed up fast enough and took my foot off the pedal to slow back down... well, this caused a really rough downshift, and I lost all power, like the car shifted into Neutral, it just rev'd when I press the accelerator. My Check Engine light came on & I had to pull over, put the car into park & then was able to put it back into gear & get going.
I stopped at home, planning to take the car to the dealer the next day. When I went to start it up again, the light was off... so I didnt do anything. It ran normal until this weekend...
2 days ago, I was driving on the hwy about 55mph and my ABS, traction control & ESP/ BAS lights all came on at the same time. I noticed no difference in the driving or braking and nothing to indicate to me there was a problem.
Today, I was speeding up to get on the freeway just like ^^ and I lost all power and my check engine light came on. I drove directly to the dealer. It threw the code P0730 and a code about the Right Rear Wheel Speed Circuit (sorry, dont have the code #)
Dealer says they need to take out the tranny & tear it apart to find the problem. I bought a Power Train warranty w/ it back in April. The Dealer told me that they dont know if the warranty will cover it until they have it out, taken apart and pinpoint what part is bad... at that point, if its not covered, I'm looking at a rebuild of my tranny and some major $$$.
This just doesnt sound right to me... Has anyone been through this before or experienced this problem? Any suggestions on what I should do? :confused:
The car runs fine and I am able to drive it.. sometimes it does have a rough downshift but not always.

05WK 07-11-2011 10:24 PM

Re: Transmission problem?
 
That's why we here call them the stealership, lol. And as far as The acceleration, then going into neutral, that's normal. I believe it's the computer preventing any harm done. I have had this happen to me a time or two. Just gotta be careful.

Before you go extreme and have them take it apart, try reseting the computers. Take both battery terminals off for about 15minutes. Then put them back on and If the warning lights come back on perminatly I would still get a second opinion from a local tranny shop.

You may just need the trans fluid and filter changed out.

lll2for3lll 07-11-2011 10:28 PM

Re: Transmission problem?
 
Happen to me too. They say the hard downshift is normal. I haven't had a hard downshift since I installed 32" tires though. But the PCM was flashed right before that.

TB_Jeep 07-11-2011 10:33 PM

Re: Transmission problem?
 
If I reset the computers, and the lights go out, should I just not worry about it then?
I only have about 4000 miles left on my warranty. (Just drove it across country and to hell & back thanks to the Military) So, if there really is a problem, I'd like to get it fixed before then.
stealership, lol!

05WK 07-11-2011 10:38 PM

Re: Transmission problem?
 
There is an aprox. 50mile reset time period after. If there is a problem, they will come back on. I still recommend the trans fluid be replaced.

TB_Jeep 07-11-2011 10:46 PM

Re: Transmission problem?
 
Thanks! I'll look into getting the fluids replaced. So, sounds like I might have just driven it weird or something & the downshift is normal?
Is flashing the PCM the same as resetting the computer? Sorry if thats a dumb question.. If not, do I need to flash the PCM and how do I do that?
Any idea about the other lights?

lll2for3lll 07-11-2011 10:56 PM

Re: Transmission problem?
 
The dealer flashes (update software) the PCM. I've heard different stories about the "hard downshift" Jeep transmission which leaves me at bit concerned about the product.

Has me in the state of mind, "Should I buy another Jeep?"

Bottom line is that since the PCM flashes and transmission fluid change, I haven't had any problems. I can make it downshift hard if I want (which is rare now because of the large tires) but still....does that mean I can't drive my Jeep the way I want without it trying to protect myself.

I've heard plenty of stories like yours in the first post about pulling into traffic, transmission downshift hard, drops in neutral to "protect" itself, and puts the people in danger in return causing accidents. Look it up. Plenty of complaints online.

But like I said, my wk has been good to me but will the next one..................

TB_Jeep 07-11-2011 11:03 PM

Re: Transmission problem?
 
This is my first SUV, first Automatic, and first Jeep... ha. It has me feeling iffy too. I didnt know what to expect.

I'll look up those complaints, thanks! Glad to know I'm not alone, but its not such a good feeling.

lll2for3lll 07-11-2011 11:06 PM

Re: Transmission problem?
 
It's not a good feeling at all. But the WK that sits outside in my driveway has been good to me for a long time now.

I had some bumps in the road but go over them. However, they did leave me with some sores which make me feel the way I feel. And also, other car enthusiasts I know personally that have owned Jeeps and the DAMN GOOD care of every thing they own and they say never again.

TB_Jeep 07-12-2011 08:08 AM

Re: Transmission problem?
 
Anyone have an idea about why my ABS, traction control & ESP/BAS light might have come on?

TB_Jeep 07-12-2011 02:47 PM

Re: Transmission problem?
 
Update: I took the battery terminals off for about 20 min. Reconnected them, the lights turned off, then flashed and came back on & stayed on. I did not/have not driven it since.
I cannot check my Tranny fluid b/c I dont have a dipstick, its a sealed tranny.. guess I need to go to the dealer to have this done. What a pain!
I have an apt w/ the dealer tomorrow.

burkey222 07-12-2011 08:07 PM

Re: Transmission problem?
 
Please keep us updated. I'd love to hear how this turns out.


All times are GMT -5. The time now is 10:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community