Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   WK Won't Unlock or Lock on Command (http://www.jeepgarage.org/f77/wk-wont-unlock-or-lock-on-command-25942.html)

Chaoul1 07-19-2011 01:56 PM

WK Won't Unlock or Lock on Command
 
A few months back I experienced a problem with my Key FOB not working. It wasn't Locking or Unlocking my Jeep at all. So what I did was I bought a new Battery for my Key FOB and I disconnected the Battery from the Jeep for 30 Seconds. And it worked after that. This happened twice in that same week.

Since then I haven't had that much of a problem since two weeks ago. Now everytime I want to go I have to keep clicking it to unlock or to lock it. I try and types of angles to unlock/lock it. But then it would randomly get it and unlock.

Now it's atthe point to where I can't unlock/lock the vehicle anymore. I called the dealership and the Service Tech told me to Insert the key into the Door (Which sets the Alarm) and turn the Ignition to the "ON" position which disables the Alarm. SO I did that and the Key FOB worked right after I did that. But before I did that he said "I need a new Key FOB." I said,"My Key FOB actually works right after that, but for a little bit. How do I need a new one if this one works right after I do the procedure you just told me?" The Tech replied,"We need to Dianose what's going on." I said I'll call you back. The Battery Cables are clean and the Key FOB has a brand new Battery.

So now If I were to go to my Jeep and unlock/lock it I would have to insert the key and unlock it manually and listen to the alarm go off and set the ignition to the "ON" position.

It doesn't work properly anymore. I disconnected the battery again after the 3rd time this happened, and it worked, but then it didn't after trying to see if it wouldn't do it to me again.

I have heard that it could possibly be my Battery effecting this or it could just be my Key FOB going out. I do have a spare at my Fathers house and I'm going to see if that one works.

I'm going to post a video up of how it's acting so you can get a clear idea. I have to find my charger first.

Thanks!

SvenskaJeepGuy 07-19-2011 02:25 PM

Re: WK Won't Unlock or Lock on Command
 
does the jeep start up and drive everytime? if so then the key fob battery is most likely fine. maybe the contacts inside the fob are going?

Chaoul1 07-19-2011 02:34 PM

Re: WK Won't Unlock or Lock on Command
 
If I try to immediately start it, it would rev up and die. THis happened the first time a few months back.

Now I set it to the "ON" Position and then start it. And no problems with start up. I'm also thinking it's either the actual battery in my Jeep or the Key FOB going bad.

But it doesn't make sense. Everytime I can't unlock it I have to do that same procedure "Insert Key" and turn ignition to "ON" Position then the Key FOB works. But 5-10 mins after that maybe more it won't work and I have to do everything all over again.

SvenskaJeepGuy 07-19-2011 02:48 PM

Re: WK Won't Unlock or Lock on Command
 
i think it is the key fob. when my battery died it would start right up and then die. since you just replaced the battery i am certain that it is the fob itself. i think it is a common problem for the contacts to break. as long as you have anothetr one you can program a new one for yourself without paying the dealer $75+ just get a new fob on ebay and put your key into it and program it.

Chaoul1 07-19-2011 02:52 PM

Re: WK Won't Unlock or Lock on Command
 
That's what I'm going to do. Any place you recommend to buy a new Key Fob? eBay?

2005JGC 07-19-2011 11:19 PM

Re: WK Won't Unlock or Lock on Command
 
wherever you buy it make sure your check the partnumber with your local dealer... I have seen people ebay keys before and bring them in to be programmed only for them to not work.

Chaoul1 07-21-2011 07:34 PM

Re: WK Won't Unlock or Lock on Command
 
I bought a brand new one off eBay. It isn't cut or anything. Hopefully this will work. My Key Fob is kind of working, but I need a new one.

SvenskaJeepGuy 07-21-2011 08:37 PM

Re: WK Won't Unlock or Lock on Command
 
hopefully! you should be able to program it yourself too and save $75

Chaoul1 07-21-2011 08:44 PM

Re: WK Won't Unlock or Lock on Command
 
Yeah I'll be able too since I have two keys of my own. So once this one get's cut I'll program it myself. If not my best friend works at Farrish Jeep in Fairfax and will get a sick discount.

SvenskaJeepGuy 07-21-2011 09:21 PM

Re: WK Won't Unlock or Lock on Command
 
i wish i had a friend at a dealer......... nevermind i spend enough there the way it is lol

Chaoul1 07-29-2011 09:18 AM

Re: WK Won't Unlock or Lock on Command
 
Just fixed it this morning!

I bought a new Factory Key of eBay, got it cut for $3 and then programmed it myself! Everything works now!


All times are GMT -5. The time now is 02:07 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community