Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Does this sound right to you? (http://www.jeepgarage.org/f5/does-this-sound-right-to-you-26015.html)

4.whoa 07-21-2011 03:41 AM

Does this sound right to you?
 
Well, my '05 is giving me "service 4wd system" along with "service elec brake system" and both ABS & ESP dash lights. sometimes its just the chime and lights, sometimes nothing at all, sometimes the brake pedal is very hard to push-then drops to the floor, and sometimes (only when its just started and in the 1st 50') it grinds and clunks something terrible and it rocks the whole thing side to side! :mad:
I took it in on fri and the dealer said it shows problems with a wheel sensor, the diffs and the transfer case, but the wheel sensor will probibaly fix it. they just got the sensor so im taking it in @ 10. What gets me is that its not always the same symptom. What do you think?

I did ask him about the flash up front and he said they'd check, but didnt say anything else about it.

JETLIFE 07-21-2011 06:24 AM

Re: Does this sound right to you?
 
Ya, could be a wheel sensor, make sure your brake lights are lighting up. I had "service electric brake system" and had no tail lights whatsoever. It was a fuse, replaced it and was good to go. The grinding and clunking doesn't sound good though. When's the last time you've serviced your diffs, transfer case, and brakes?

Sounds like you'll be getting a hefty bill!

4.whoa 07-21-2011 09:53 AM

Re: Does this sound right to you?
 
transfer case ,diffs and brakes were done about 2 months ago. dealer changed (spilled actually) a qt from the front diff when doing the mounts,i couldnt see dumping the $30 qt to get the other .8 so the front was about a 60% change.

hope it's not o much $$ to fix -I need that $ for mods :)

4.whoa 07-21-2011 11:35 AM

Re: Does this sound right to you?
 
Well,.................the tech decided to take the left front wheel sensor out, when he was supposed to change the right one and ,OF COURSE.... he broke it! :motx: So now I have to wait till tomorrow to see if that was the problem.

Kreso 07-21-2011 12:10 PM

Re: Does this sound right to you?
 
I had the same symptoms. It was a wheel sensor (right sensor I think). Sensor replaced. All is OK ever since

JETLIFE 07-21-2011 12:25 PM

Re: Does this sound right to you?
 
Glad you got it figured out!

4.whoa 07-22-2011 01:13 PM

Re: Does this sound right to you?
 
It's Fixed :joe: It's funny though, the original bad sensor made it do all that weird crap, but with it replaced, and the one HE broke scraping as I drove, all it did was ping and the dash lights were on. it ran totally fine. Oh well, its good to have her back on track :D


All times are GMT -5. The time now is 04:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community