Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Symptoms of Bad Engine Mounts (http://www.jeepgarage.org/f203/symptoms-of-bad-engine-mounts-2621.html)

CherokeeChief 09-11-2009 04:33 AM

Symptoms of Bad Engine Mounts
 
I was wondering which are the symptoms of bad engine mounts. I feel a slight vibration on my gas pedal, shifting is not perfect (feel like trans is slightly slipping) especially between 2nd and 3th during hard acceleration and I feel a little loss of power, like someone is pressing and releasing the brake pedal. I already changed my trans mount and I know my motor mounts are broken, one has the rubber completely disconnected from the metal. Could be these symptoms related to bad engine mounts ?

saleen032 09-11-2009 06:56 AM

Re: Symptoms of Bad Engine Mounts
 
I highly doubt it, but I guess it could be possible that if the mounts were "toast", that the engine couldmove enough to maybe cause an electrical connection to start coming apart...causing issues....but I really dont think that is happening

CherokeeChief 09-11-2009 07:03 AM

Re: Symptoms of Bad Engine Mounts
 
I don't think to an electrical problem... I don't have codes with the 3 On/Off and the dealer checked it with the DRB Scan tool. The dealer says that everything is ok. He just upgraded my Trans SW for the second OD, but I have these issues before i did it.

RedRocker 09-11-2009 09:51 AM

Re: Symptoms of Bad Engine Mounts
 
The vibration in the gas pedal is probably your engine mount. The hesitation/slipping is probably your transmission. Have you had it serviced regularly including band adjustment? How many miles?

(Incidentally, you can check for broken motor mounts by opening your hood and pushing in on the throttle linkage by hand to "goose" the engine. If the mounts are good, you should see just a little vibration in the engine, if the mounts are gone, you'll see a more dramatic vibration.)

DJ BoNiOmArIo 07-16-2010 09:25 AM

Re: Symptoms of Bad Engine Mounts
 
need to find transmission and motor mounts for my WK I'm having no luck :(

Will the liberty mounts fit ?

Cautiousone 04-27-2017 08:53 PM

Re: Symptoms of Bad Engine Mounts
 
How serious a problem is a busted motor mount. I Feel no vibration but wonder would it affect my power seeing that I live in the mountains. Dealership happened to find it when I took it in for Four Wheel drive light

Governor 04-27-2017 09:58 PM

Re: Symptoms of Bad Engine Mounts
 
Depends on which side it is. The left side will lift the engine if you hold the brake in drive and give it a little gas because of the direction the crank turns and the torque from the engine in that direction. The other side is pretty much held in place by the direction of torque. It won't pick up the engine but it can move around a little bit. This is assuming the rubber is still in place but split all the way across.

If you are trying to get by for awhile with the left side, you can strap it down with a ratchet strap from the left side of the engine to somewhere on the left inner fender. My 70 Charger 440 would rip the left side out of the engine mount so often I had to chain it down on that side with a turn buckle.

Left and right on a vehicle is when you are sitting in the seat facing forward.

Cautiousone 04-28-2017 01:35 PM

Re: Symptoms of Bad Engine Mounts
 
Quote:

Originally Posted by Cautiousone (Post 2020498930)
How serious a problem is a busted motor mount. I Feel no vibration but wonder would it affect my power seeing that I live in the mountains. Dealership happened to find it when I took it in for Four Wheel drive light

Thanks Governor


All times are GMT -5. The time now is 08:31 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community