Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   ESP BAS light (http://www.jeepgarage.org/f181/esp-bas-light-26294.html)

TJXJWJ 07-27-2011 12:28 PM

ESP BAS light
 
Hi everybody! So the wife's 06 3.7L Laredo is acting up. The ESP BAS light is coming on along with the traction control light (swirvy road indicator). By the time she gets home from her 10 minute drive home, it's shut itself off, so I never get to see it. It runs fine, and she drives like an 80 year old woman. No codes either.

I HATE taking it to the dealer...any way for me to diagnose? I'd rather spend $$ on parts than on a diagnostic that will likely not turn anything up because the light is off and there are no codes.

Should I start replacing wheel speed sensors? It's got new front brakes (a few months old) and no alignment issues. Tracks straight.

2005JGC 07-28-2011 01:25 AM

Re: ESP BAS light
 
there are WAY to many things to just start replacing parts unless your just looking for a completely refreshed vehicle ;)

Honestly, with things beyond the check engine lamp that will require a scantool that can talk to other modules, I really suggest taking it in and having it looked at, there will likely be stored codes in the abs or other module like the scm that can lead to disabling of the abs system. Its crappy and I fully understand not wanting to waste money on diag but its is there for a reason, if for nothing more than to get the codes that are stored and then we can go from there on here.

TJXJWJ 07-28-2011 07:01 AM

Re: ESP BAS light
 
Damn reasonable next step....heheheh.
Ok, so I disconnected the sensors, re connected, checked all the fuses under the hood. Nothing looked frayed, popped, or out of place. I took it for a short spin (according to the wife, it comes on pretty quickly) and no ESP light. Another tidbit of info is that it's not happening to her on her way to work, only on her way home, which is really friggin strange.
Anyhow, if the light comes back on (and I expect it to), it'll be off to the dealer for a diagnostic. Any tips on what questions to ask or what to expect for my diagnostic fee? Is it realistic to expect them to be able to pinpoint the problem for my diagnostic charge? If it's a speed sensor or a dragging brake or something, I can do that. If it's a clockspring, I've never done that before...no clue where to even start.

I'll report back with any developments...thanks Andrew!

Kreso 07-28-2011 08:13 AM

Re: ESP BAS light
 
Most probably is one of the speed sensors(front right). It's on the way to go. Stealership can test them.

TJXJWJ 08-04-2011 08:51 PM

Re: ESP BAS light
 
OK, just for the record...I unplugged the front driver's sensor harness, looked clean...plugged it back in. Checked all the fuses under the hood...light has not been on in about a week now. Hopefully it stays off!

Tumber 11-20-2012 10:43 AM

Re: ESP BAS light
 
Quote:

Originally Posted by TJXJWJ (Post 460122)
OK, just for the record...I unplugged the front driver's sensor harness, looked clean...plugged it back in. Checked all the fuses under the hood...light has not been on in about a week now. Hopefully it stays off!

I am having the same issue, and I can't find the harness. Can you tell me exactly where it is at or a picture or something? :-(

TJXJWJ 11-20-2012 11:08 AM

Re: ESP BAS light
 
Quote:

Originally Posted by Tumber (Post 713467)
I am having the same issue, and I can't find the harness. Can you tell me exactly where it is at or a picture or something? :-(


Sorry dude...that Jeep sold last month...I don't have it anymore to take a pic of. I'm pretty sure the sensor harness was visible by just looking behind the tire, in the wheel well, near the shock, but I honestly can't remember. This thread is pretty old...all I know is that it never came back on for us.

Tumber 11-20-2012 11:28 AM

Re: ESP BAS light
 
It's all good. I am just trying to figure this dang thing out because I can't afford to take it in.

TJXJWJ 11-20-2012 12:49 PM

Re: ESP BAS light
 
Yeah dude...I feel ya. "Diagnostics" are friggin expensive. Definitely try unplugging the sensor, cleaning the connection if needed, and resetting the computer by pulling the negative on the battery. The speed sensor should be the only wire coming out from behind the wheel.

DAVY27 12-18-2012 03:06 PM

Re: ESP BAS light
 
hateeee to bump this thread up....but just noticed my ESP/BAS light being lit.

Im going to try the wheel right,left,center and disc the bat if that doesnt work..

Will something as simple as brake pads wearing out cause this light to stay on? My rear pads are wearing out but didnt get a chance to replace it yet.

Tumber 12-18-2012 03:17 PM

Re: ESP BAS light
 
Quote:

Originally Posted by DAVY27 (Post 726149)
hateeee to bump this thread up....but just noticed my ESP/BAS light being lit.

Im going to try the wheel right,left,center and disc the bat if that doesnt work..

Will something as simple as brake pads wearing out cause this light to stay on? My rear pads are wearing out but didnt get a chance to replace it yet.


One thing to check if the sensors look clean is to check the steering wheel. If it is angled, straighten it and that might fix it. My steering wheel wasn't straight and I took my jeep in to get the oil changed, aligned, and straighten the wheel and that resolved the issue.

DAVY27 12-18-2012 04:17 PM

Re: ESP BAS light
 
thx bud!

everything seemed fined. did the wheel turn, shut off and restarted the jeep but light stayed on. Same wit Disconnectin the battery. After that i just whipped it around the block and light went off so everything in the world is good lol.

If it reoccurs i'll probably just take it to the dealer.


All times are GMT -5. The time now is 12:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community