Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Visual Modifications (http://www.jeepgarage.org/f7/)
-   -   Switchback Problem (http://www.jeepgarage.org/f7/switchback-problem-26646.html)

DAVY27 08-04-2011 04:10 PM

Switchback Problem
 
Just recently i experienced some problems with my passenger side switchbacks(type AW from autolumination)I installed 2 months ago with no problems. At first i was getting the rapid blink, so i check the connections of the splice clips and found out the locking tab broke off so i replaced it with another one. No rapid flash, problem solved. But one night as i was pulling into my driveway i noticed the passenger side switchback was lit amber instead of white when my parking lights were on. I thought it was the connections so i doubled check all the splice clips and they seem to be in place. It would seem fine for the first minute when the parking light is on, stays white, but eventually it turn amber. NO rapid blink either, at times it would just blink white and not amber.

What can be the cause of this? Can it be the bulb or resistor(do they even go bad?)

robpp 08-04-2011 04:15 PM

Re: Switchback Problem
 
dave it SOUNDs like the bulb. i dont think its the resistor.

maybe try Autolumination for a replacement. make a vid or something so they can see what you talking about. also tell them its been good for a while.

lll2for3lll 08-04-2011 05:05 PM

Re: Switchback Problem
 
Sounds like the bulb to me too. If it was the resistor, you would get the rapid flash as if the resistor wasn't there.

Get another bulb. Try V-LEDS if you want. They have them in stock.

DAVY27 08-04-2011 05:24 PM

Re: Switchback Problem
 
that was what i was afraid of :(.

good looking out Rob and 2for3! Doh, ill just switch the passenger and driver side bulbs to confirm

B.P.O.D 08-05-2011 02:08 PM

Re: Switchback Problem
 
def sounds like bulb bro:(

DAVY27 08-05-2011 08:30 PM

Re: Switchback Problem
 
yea, tried the bulb on driver side and same result :( ill shoot autolumination an email to see what they can do for me.

B.P.O.D 08-15-2011 11:02 AM

Re: Switchback Problem
 
if u had the same result then i'm guessing its the resistor. did u try the passenger bulb in driver side?

lll2for3lll 08-15-2011 11:10 AM

Re: Switchback Problem
 
He tried it on the other side and had the problem with the same bulb again. It was the bulb. Not the resistor.

SRTILL8 08-15-2011 11:10 AM

Re: Switchback Problem
 
hey davy, i got both sets of vleds switchbacks- if you want to try my vleds to see how itll work. just holler!

gl bro

lll2for3lll 08-15-2011 11:11 AM

Re: Switchback Problem
 
^^^You need to go for that. Lol. Send him a PM SRTILLA.

JeepCoop 08-15-2011 11:26 AM

Um, what are switchbacks?! :)

lll2for3lll 08-15-2011 12:16 PM

Re: Switchback Problem
 
Quote:

Originally Posted by CoopCooper (Post 466168)
Um, what are switchbacks?! :)



All times are GMT -5. The time now is 11:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community