Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f183/)
-   -   water pump died! (http://www.jeepgarage.org/f183/water-pump-died-27144.html)

dc300m01 08-15-2011 07:45 PM

water pump died!
 
1 Attachment(s)
On my 2008 WK 3.7. Doing 70mph on the PA turnpike, heading to DC for vacation. Went to take a turn and and the PS was gone! I was able to ease it over to the shoulder and turned the engine off and the steam was pouring out from under the hood. It took the belt out, which was about 50ft behind us on the highway. Got it towed to the nearest dealership, which was of course closed on Sunday (I knew that before getting it towed there).

I thought it was just the belt that broke... so I contemplated having the tow truck operator drive us to Advance Auto and I'd throw a new belt on and be on our way... but my wife wasn't comfortable doing that, so we left it and got a rental. Thank goodness she didn't want me to fix it!

Pump and tensioner are covered under warranty (only 36,000 mi). Can't believe the pump went out this early. Anything I should watch out for? I only drove maybe 100 ft after the belt broke and immediately turned the engine off and popped the hood. Sat for about 40 minutes until the tow truck showed up. Only started the engine again to park it at the dealer.

On a good note, our rental is a red 2011 Grand Cherokee. First time I drove one and I'm in love. Not to mention avg 25mpg on the way down is great, compared to the 18 on mine.

Here's our jeep and the rental when we went back to grab our bags to continue our trip.

remmy 08-15-2011 07:51 PM

Re: water pump died!
 
Unless it trashed your timing chain I think it will be fine. Im pretty sure mine is going out even though the noise could be the new PS pump that may be bad... Ill have mine checked out tomorrow.

Crestwood1001 08-15-2011 10:59 PM

Re: water pump died!
 
Hey at least you made the best outta it. Its covered and you got a nice rental! Enjoy your vacation man

ChrisWk 08-16-2011 04:26 PM

Re: water pump died!
 
My water pump was replaced on my 05 wk in may 2011 under power tran warranty.

Drew 08-16-2011 04:49 PM

Re: water pump died!
 
Mine was just done at 43k. Went out the same as yours all of a sudden and actually blew a big hole in the bottom of the pump housing just behind the pully area. However, mine was whining quite a bit for about a month or so prior. I thought the whining was the power steering pump.....boy was I wrong..:D

lll2for3lll 08-16-2011 05:14 PM

Re: water pump died!
 
Mine was whining few years back but only because it was low on fluid.

Same pump at 89,000 miles.

Maybe because I NEVER turn my wheel at full lock like a granny.

dc300m01 08-16-2011 06:20 PM

Re: water pump died!
 
Quote:

Originally Posted by Drew (Post 467113)
Mine was just done at 43k. Went out the same as yours all of a sudden and actually blew a big hole in the bottom of the pump housing just behind the pully area. However, mine was whining quite a bit for about a month or so prior. I thought the whining was the power steering pump.....boy was I wrong..:D

I had whining too... but didn't think anything of it. Kicking myself for that. I know better. :mad: In my 300M; the pump is driven by the timing belt and is good for 100k. If the belt brakes... major trouble. I replaced that at 108k. Considering I had to remove the entire front of the car to change that, I'm glad to see the pump on this is relatively easy.


All times are GMT -5. The time now is 03:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community