Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Help Me! Please Read! Video Included! (http://www.jeepgarage.org/f5/help-me-please-read-video-included-27291.html)

lll2for3lll 08-18-2011 05:15 PM

Help Me! Please Read! Video Included!
 
My WK started bucking really bad after I had a mechanic look at it. I noticed that he pulled a vacuum line while it was running.

After he looked at it, the check engine light was on but I didn't pay it any attention. After driving it for a while, the engine light began to flash and that when I started to worry.

I then noticed that when I accelerate heavily, I get very bad surging/bucking at around 40mpg @ 3,000rpm.

I checked the hoses. They are connected. He only pulled on hose and immediately put it back on.

You will get a very good look at it towards the end of the video.


lll2for3lll 08-18-2011 05:20 PM

Re: Help Me! Please Read! Video Included!
 
It's having hard time cranking now.

thex2 08-18-2011 05:36 PM

Re: Help Me! Please Read! Video Included!
 
I wouldn't keep running it like that. Wait till somebody helps you out. That way you don't risk breaking something else in the mean time.

jeff05wk 08-18-2011 05:37 PM

Re: Help Me! Please Read! Video Included!
 
Sounds like a mechanic is due an ear full, and an ass whoopin.

Hope you can get that taken care of bro. Sounds aweful!

viking757 08-18-2011 05:41 PM

Re: Help Me! Please Read! Video Included!
 
What DTC codes are coming up?

DaBigBone 08-18-2011 05:50 PM

Re: Help Me! Please Read! Video Included!
 
Usually a flashing CEL means a misfire

lll2for3lll 08-18-2011 06:09 PM

Re: Help Me! Please Read! Video Included!
 
Got the codes.

P0339
P0300

Funny thing is that it's not doing it anymore. The engine light is still on but it's not in flash mod anymore (it's not continuously flashing like it was when I had the problem).

lll2for3lll 08-18-2011 06:11 PM

Re: Help Me! Please Read! Video Included!
 
Quote:

Originally Posted by DaBigBone (Post 468737)
Usually a flashing CEL means a misfire

That's exactly what code P0300 is. I'm at Advance Auto right now with the machine. They give it to you to use in the parking lot for free. :lol:

DGoral31 08-18-2011 06:12 PM

Re: Help Me! Please Read! Video Included!
 
dude what a burn...

if i were you i'd get on the phone with that mechanic ASAP and let him know whats up!!

AcidCold 08-18-2011 06:14 PM

Re: Help Me! Please Read! Video Included!
 
Disconnect your negative for 5 minutes or so, I bet the light will go away.

lll2for3lll 08-18-2011 06:25 PM

Re: Help Me! Please Read! Video Included!
 
Quote:

Originally Posted by AcidCold (Post 468754)
Disconnect your negative for 5 minutes or so, I bet the light will go away.

I cleared the code with the machine already.

What do you think is was Acid?

I shouldn't have that problem even if the guy pulled the vacuum line while it was running.

Could I have a vacuum leak somewhere?

WTF? Lol.

The CEL is gone and it hasn't come back.

lll2for3lll 08-18-2011 06:28 PM

Re: Help Me! Please Read! Video Included!
 
Wait.....I'm currently driving down the road and it's doing it again. But no CEL. WTF!


All times are GMT -5. The time now is 06:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community