Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Swapped grille...now sluggish V6 (http://www.jeepgarage.org/f107/swapped-grille-now-sluggish-v6-27369.html)

Kindnug 08-20-2011 11:28 AM

Swapped grille...now sluggish V6
 
Hey all. Two days ago I swapped out my limited grille for an overland one, and it looks great. However, since then I'm noticing issues with acceleration, especially off the line or on the highway. I push the pedal all the way down and it takes like 2-3 seconds for the engine to shift gears and accelerate now. My GC was built in 6/11 and prior to the grille swap the V6 worked like a champ, no issues at all.

I noticed that the instructions for changing the grille said to disconnect the negative battery cable. Is it possible that this might have 'reset' the programming of the V6, thereby losing any updates/TSB's that may have been programmed prior to it leaving the factory?

I know I'm not crazy and there is definite difference in driveability since I had the grille changed out. Any thoughts would be greatly appreciated.

AAAA 08-20-2011 12:06 PM

Re: Swapped grille...now sluggish V6
 
That sucks. Why the battery disconnect??

Kindnug 08-20-2011 12:17 PM

Re: Swapped grille...now sluggish V6
 
I have no idea other than that's what the instructions for changing the grille said. In fact, I'm not even sure if the battery was disconnected because I didn't do the grille work myself. All I know is that it doesn"d drive/accelerate the same as it did prior to modification.


All times are GMT -5. The time now is 04:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community