Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Troubles starting with ABS, please help! (http://www.jeepgarage.org/f77/troubles-starting-with-abs-please-help-27387.html)

H2rescue 08-20-2011 06:01 PM

Troubles starting with ABS, please help!
 
Just hopped in the Jeep yesterday and took off down the road and after bout 2 minutes of driving I had abs and some other lights come on along with service 4wd system. After a minute or so it went off.

Today got in and was stopping at a light and the abs kicked on under normal stopping conditions. And it has been kicking on randomly.

Can someone please shed some light on what's going on? Please!

It's my first WK, and I've only had it a couple of months now. The lift and tires have been on for bout a month.

2005JGC 08-22-2011 12:11 PM

Re: Troubles starting with ABS, please help!
 
this could be ALOT of things, I have seen dying wheel speed sensors cause intermittant abs events because one wheel speed sensor drops out... typically this will throw a rationality code and turn your abs light on and when there is an active abs code you have no abs. Ultimately it would be throwing very expensive darts at a dartboard without knowing what the car has to offer in the information department having codes pulled.

H2rescue 08-22-2011 12:35 PM

Getting it scanned this afternoon. Hopefully that will tell me something. But today on the way to work, the service 4wd system popped up along with the abs, bas, eas, and traction control symbol. Stayed on the whole way to work which is bout 30 min drive.

H2rescue 08-22-2011 07:19 PM

Got it scanned today. Not showing any codes. Funny cuz while I had scanner connected, it was showing ABS, ESP, BAS, traction control symbol was on as was the service 4wd system.

Anyone have suggestions as to where to move from here?

2005JGC 08-23-2011 12:18 PM

Re: Troubles starting with ABS, please help!
 
a generic scanner wont pull abs or fdcm codes... ONLY pcm. Your going to need a dealership to scan it with the witech.

H2rescue 08-23-2011 12:50 PM

Quote:

Originally Posted by 2005JGC (Post 471317)
a generic scanner wont pull abs or fdcm codes... ONLY pcm. Your going to need a dealership to scan it with the witech.

Yea ima double check the wheel speed sensors and wires to see if there's any obvious problems. If nothing turns up I'm going to walmart an buy some ky and head to dealership.

raedalwan 10-20-2011 10:07 AM

Re: Troubles starting with ABS, please help!
 
is your problem solved? i have the same

H2rescue 10-20-2011 12:17 PM

Quote:

Originally Posted by raedalwan (Post 501410)
is your problem solved? i have the same

Yep, took it to dealer n had it scanned. Said it was front right hub assembly. It still felt tight, wasn't any play in it but I replaced it and problems have gone away!


All times are GMT -5. The time now is 08:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community