Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior/Visual (http://www.jeepgarage.org/f182/)
-   -   Frustrated with HIDs (http://www.jeepgarage.org/f182/frustrated-with-hids-28008.html)

2005 WK 09-02-2011 10:03 PM

Frustrated with HIDs
 
So I just bought a new set of hid's cause my last ones were acting up. Now I am having the same problem with these and they have been in since last night. At first i installed them without a relay and they worked but flickered a lot and when i turn the lights off they would strobe like police light for approx. 30 seconds then shut off. Today i installed a relay to them and they turned on and off just fine when i first tested them. I just got to work and went to turn them off and they wouldn't turn off so the only thing I could do until tomorrow is unplug the relay. I also noticed they were still flickering a little bit even with the relay. Any suggestions on what I should do.

Crestwood1001 09-02-2011 10:11 PM

Re: Frustrated with HIDs
 
Well while we wait for Rob to get in here and fix this, just be aware that strobbing like that is VERY bad for the HID system, they dont like being turned on and off like that.

2005 WK 09-02-2011 10:13 PM

Re: Frustrated with HIDs
 
ya, i fixed the strobing issue with the relay, but now they wont turn off so i had to unplug the relay. i noticed they were also flickering a bit on my drive in to work.

Crestwood1001 09-02-2011 10:14 PM

Re: Frustrated with HIDs
 
Gotta be a relay issue my man.

2005 WK 09-02-2011 10:20 PM

Re: Frustrated with HIDs
 
just bought it brand new from radio shack cause my old one was broken. They work just fine when i first tested but after a 40 min drive i went to shut them off and got nothing.

H2rescue 09-02-2011 11:10 PM

Quote:

Originally Posted by Crestwood1001 (Post 477986)
Gotta be a relay issue my man.

X2
Relay may be getting jostled around from vibrations while driving. How do you have it mounted? Do you drive on rough roads?

05WK 09-02-2011 11:22 PM

Re: Frustrated with HIDs
 
Or it could be the multifunction switch.... Not trying to worry you more... :D

It's known to do wacky flickering and strobing...

2005 WK 09-02-2011 11:29 PM

Re: Frustrated with HIDs
 
Quote:

Originally Posted by H2rescue (Post 478032)
X2
Relay may be getting jostled around from vibrations while driving. How do you have it mounted? Do you drive on rough roads?

I have it mounted on my inner fender, and no, i do all my driving on paved roads and highways. im thinking i just got a poor quality kit.

H2rescue 09-02-2011 11:35 PM

Quote:

Originally Posted by 2005 WK (Post 478046)
I have it mounted on my inner fender, and no, i do all my driving on paved roads and highways. im thinking i just got a poor quality kit.

Yea it could def be from the quality of the kit. I bought a cheap kit once for my wrangler, you could squeeze the relay pack and my lights would shut off.

Scottina06 09-03-2011 03:29 PM

Re: Frustrated with HIDs
 
what hid kit?

lets see that relay harness....

TurboDiesel 09-03-2011 03:49 PM

Re: Frustrated with HIDs
 
how is the relay harness wired?

Crestwood1001 09-03-2011 06:36 PM

Re: Frustrated with HIDs
 
I got a 55w kit from DDM tuning for cheap and it works great...


All times are GMT -5. The time now is 11:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community