Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Sigh - 13 days and back to the dealer she went (http://www.jeepgarage.org/f5/sigh-13-days-and-back-to-the-dealer-she-went-28437.html)

JMLoughrey 09-12-2011 10:26 AM

Sigh - 13 days and back to the dealer she went
 
Well, Purchased my 2007 WK 3.7L two weeks ago tuesday. Sadly, she's ALREADY going back to the dealer.

Driving home last night, the WK completely shut down, or so i thought. Gauges dropped to zero, evic died, odometer died but she was still running. After a minute everything kicked back on, check engine light came on, TCS light came on, headlights started flickering, and a few other lights came on, looked like a christmas tree. All other controls in the vehicle were unresponsive, windows, locks, sunroof, TCS, blinkers, radio ETC.

I still had power steering, brakes (dont know about the lights) and parking lights, limped her to the dealer as i was luckly driving by and went by this morning.

Currently driving a rental (on the dealers dime) until i hear from them abuot what the issue is. Not all that happy, less then 2 weeks in, i've had more problems with this jeep then i did with my old Jeep Liberty or Nissan Xterra.

I tried to pull the code but my scanner just read ERROR. And with the evic not working that was no help to me.

Anyone got any ideas on what it could be? I'm still under warrenty as i've only had it 2 weeks and i have a 90 day 5k mile warrenty.

viking757 09-12-2011 10:29 AM

Re: Sigh - 13 days and back to the dealer she went
 
Quote:

Originally Posted by JMLoughrey (Post 483203)
Well, Purchased my 2007 WK 3.7L two weeks ago tuesday. Sadly, she's ALREADY going back to the dealer.

Driving home last night, the WK completely shut down, or so i thought. Gauges dropped to zero, evic died, odometer died but she was still running. After a minute everything kicked back on, check engine light came on, TCS light came on, headlights started flickering, and a few other lights came on, looked like a christmas tree. All other controls in the vehicle were unresponsive, windows, locks, sunroof, TCS, blinkers, radio ETC.

I still had power steering, brakes (dont know about the lights) and parking lights, limped her to the dealer as i was luckly driving by and went by this morning.

Currently driving a rental (on the dealers dime) until i hear from them abuot what the issue is. Not all that happy, less then 2 weeks in, i've had more problems with this jeep then i did with my old Jeep Liberty or Nissan Xterra.

I tried to pull the code but my scanner just read ERROR. And with the evic not working that was no help to me.

Anyone got any ideas on what it could be? I'm still under warrenty as i've only had it 2 weeks and i have a 90 day 5k mile warrenty.

Could be your ignition switch failing. Its not uncommon

Check this thread out
http://jeepgarage.org/showthread.php?t=15736

Edit: Also check the obvious like your battery connection

Drew 09-12-2011 03:01 PM

I bet Your scanner said error because it is out of date. I ran into the same issue as mine was obd2 but not obd2 "can" compliant. The can bus system changed in 05ish? I updated my scanner and all is good.

As for the issue, was the jeep ever in a flood or show signs of being under water for a long time?


Sent from my iPhone using Tapatalk

JMLoughrey 09-12-2011 08:23 PM

Re: Sigh - 13 days and back to the dealer she went
 
Quote:

Originally Posted by Drew (Post 483417)
I bet Your scanner said error because it is out of date. I ran into the same issue as mine was obd2 but not obd2 "can" compliant. The can bus system changed in 05ish? I updated my scanner and all is good.

As for the issue, was the jeep ever in a flood or show signs of being under water for a long time?


Sent from my iPhone using Tapatalk

Scanners fully up to date, used it on numerous jeeps and can vehicles over the passed few weeks.

As far as i know, and from what i can see, no water damage to the interior, nothing on carfax to imply any flood damage, it had the headgasket and timing belt replaced by the dealer before i bought it. Aside from that, i got nothing.

On an Update: Jeep will be keeping the vehicle over night, there are 13 stored codes from the incident. Ranging from electrical, to mechanic to everything in between.

burkey222 09-13-2011 08:37 AM

Re: Sigh - 13 days and back to the dealer she went
 
I wonder if it's the chip. I had something similar happen years ago, and the cpu was toasted. Keep us updated, I'd be interested in hearing more.

robpp 09-13-2011 10:44 AM

Re: Sigh - 13 days and back to the dealer she went
 
what chip. i didnt see CHIP mentioned anywhere.........

burkey222 09-13-2011 11:21 AM

Re: Sigh - 13 days and back to the dealer she went
 
I agree it wasn't mentioned. I'm just saying I've had a similar issue to what the OP described, and a burnt ECU was my problem. I'm not saying it's his problem, I was just wondering outloud.

JMLoughrey 09-13-2011 03:51 PM

Re: Sigh - 13 days and back to the dealer she went
 
Well, an updated, get a call this morning, they can't duplicate the problem, therefore can't fix it. Said they did however reflash the ECU.

Go return my rental, walk across the street, get my keys, start it, bang, check engine light on, gauges off, horn honked once and one headlight was on. Service writer was standing right there.

Starting to regret buying this car, may be speaking with them about buying it back. I've had it two weeks, certified Jeep, from a well known Jeep Dealer...not a happy camper.

antsjeep 09-14-2011 07:30 AM

Re: Sigh - 13 days and back to the dealer she went
 
if they cant fix it, i would definitely look into handing the car back to them and demanding another WK.

burkey222 09-14-2011 08:23 AM

Re: Sigh - 13 days and back to the dealer she went
 
I don't blame you for being frustrated. Personally, electrical problems always worry me. If it were me, I would begin the conversation of a return now. Sorry man.

JMLoughrey 09-14-2011 10:30 PM

Re: Sigh - 13 days and back to the dealer she went
 
Well, talked to them today, they basically said in a nutshell, "we dont take cars back, F*ck off" I think i'll be calling Jeep in the morning.

maxst2 09-15-2011 12:07 AM

Re: Sigh - 13 days and back to the dealer she went
 
You have had it for 2 weeks.. there is ALWAYS a warranty that covers a car from bumper to bumper for at least a month.

IMO if they don't fix it raise hell. Really...raise hell in the middle of the day with customers all around you. You'll get taken care of right away.


All times are GMT -5. The time now is 07:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community