Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f183/)
-   -   MDS Functioning Properly? (http://www.jeepgarage.org/f183/mds-functioning-properly-28591.html)

hazards280 09-15-2011 08:55 PM

MDS Functioning Properly?
 
I really want to know if this is working or not.....im not ranting about gas mileage per say, but it is in the back of my head. I bought the Jeep knowing it would suck but

As many of you probably know, I just bought myself a 2005 Grand Cherokee Limited.

Mods right now include, 2" Terraflex Lift, 265/70-17 BFG All Terrains, Magnaflow Cat-Back Exhaust and CAI.

I know the HEMI's are supposed to have 5w-20 oil, however the previous owner did not tell me what oil he ran in the Jeep. He has this light wired up that turns on whenever MDS kicks in, and well ....I've only seen it light up twice.

I drove on the highway, going 60-65 mph this last week for about 50 miles and only got about 14.5 mpg, once again, the light never kicked on.

On the way home, I took another road and drove 50-55 mph and it was on for maybe 2 minutes during the whole hour drive. Avg- 15.2 mpg

I KNOW, Im driving a Jeep and Jeep and gas mileage never go together. I would be fine with 13/17 but, my avg of 10.4 city and 14 highway driving slow as can be EVERYWHERE is just disappointing.

Any ideas.

Im thinking

1. Sparkplug change, to the Champion coppers you all talk about
2. EGR Replacement
3. Ive already cleaned the TB

http://i190.photobucket.com/albums/z...IMAG0120-1.jpg

HEMI57 09-16-2011 12:06 AM

You are on the right track with those fixes. I can get my mrs to kick on for like 80-90% of highway driving. You should see that light much more and also better mileage too. Try the diy fixes and report back.

Crashtown 09-16-2011 04:09 AM

Re: MDS Functioning Properly?
 
The spark plug change alone should make a difference, since we're supposed to change them every 30K. It did for me. Went from 14MPG to 19MPG, which is closer to 20ish with the bigger tires.

Bleeding Blue 09-16-2011 06:12 AM

Re: MDS Functioning Properly?
 
Sounds obvious, but make sure your tire pressure is correct. I checked mine last week for the first time in 6-7 months and was about 7-9 lbs low in each tire and now I am getting 1-1.5 better MPG's. Also, your O2 sensors may be getting lazy.

hazards280 09-16-2011 09:24 AM

Re: MDS Functioning Properly?
 
Thanks for the help. I am going to change all 16 spark plugs tomorrow and put in some 5w-20 royal purple oil. I also believe that advance auto has a EGR valve. Is this something I can go aftermarket on? It has a lifetime warranty.

Bikemobile 09-16-2011 10:39 AM

Re: MDS Functioning Properly?
 
Your mpg computer may be reading low due to larger tires. The system thinks you are covering less overall miles/distance with bigger tires.

JeepCoop 09-16-2011 10:53 AM

Re: MDS Functioning Properly?
 
Turn your MDS off it doesn't make that much a difference IMO and If you get an exhaust, it'll sound like a 4 banger! haha

Def cleaning everything, staying on top of maint, and everything else everyone said works well too! :thumbsup:

Walt 09-16-2011 07:17 PM

Re: MDS Functioning Properly?
 
Certain pending DTC's (like O2 sensors) will disable MDS. Definitely disabled with a MIL that is emissions-related.

dmsfun 09-19-2011 08:18 AM

Re: MDS Functioning Properly?
 
Quote:

Originally Posted by hazards280 (Post 485609)
Thanks for the help. I am going to change all 16 spark plugs tomorrow and put in some 5w-20 royal purple oil. I also believe that advance auto has a EGR valve. Is this something I can go aftermarket on? It has a lifetime warranty.


The egr from advanced auto works fine; I put one in and it costs $39 versus the dealer charge of $ 119. My recommendation is Do not use Royal Purple with the Hemi though, as I used it for 2 oil changes and will never use it again. The MDS does not work properly with this oil and is rough when it kicks in and shuts off. RP is thicker than what they spec, and the engine ran rougher as well. I swithced to Valvoline synpower and it is far smoother and runs much better.
Your mpg should be calculated rather than going by the reading on the display as your tires are not stock diamter and that throws off the reading.

hazards280 09-19-2011 09:42 AM

Re: MDS Functioning Properly?
 
Quote:

Originally Posted by dmsfun (Post 486856)
The egr from advanced auto works fine; I put one in and it costs $39 versus the dealer charge of $ 119. My recommendation is Do not use Royal Purple with the Hemi though, as I used it for 2 oil changes and will never use it again. The MDS does not work properly with this oil and is rough when it kicks in and shuts off. RP is thicker than what they spec, and the engine ran rougher as well. I swithced to Valvoline synpower and it is far smoother and runs much better.
Your mpg should be calculated rather than going by the reading on the display as your tires are not stock diamter and that throws off the reading.

I ended up using the EGR from advanced,changing the spark plugs, seafoaming through the brake booster line, as well as doing a Mobil 1 5w-20 oil change.

The MDS still refuses to kick in on the highway, even at 65. The truck however did get roughly 15 mpg on the highway, which im okay with.

Im just contemplating removing MDS all together. If it doesn't stay on, I would rather not deal with the engaging and disengaging all the time.

HEMI57 09-19-2011 11:21 AM

Re: MDS Functioning Properly?
 
I would take care of the issue before disabling and forgetting about it. You may have some sensor off/broken somewhere or tranny issues or something random. Get it checked out!

dmsfun 09-19-2011 11:48 AM

Re: MDS Functioning Properly?
 
Soething ain't right if you only get 15 mpg. I get over 20 mpg now at 65 mph with '06 Overland 5.7 and just a CAI. Part off this is probably due to the engine loosening up; New it was under 18.


All times are GMT -5. The time now is 02:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community