Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Off Road Modifications (http://www.jeepgarage.org/f42/)
-   -   OME front strut question (http://www.jeepgarage.org/f42/ome-front-strut-question-28665.html)

Gymkata 09-17-2011 09:07 PM

OME front strut question
 
I just finished installing the MD OME suspension on my 08 WK Overland (Holy crap what a PIA...yes I'm a newb to DIY suspension). I test drove it around the neighborhood and heard all sorts of clanking. I realized that the front struts must not be tightened enough and the nuts securing the struts to the engine bay are clanking up and down. I tried tightening them from the top, but it isn't working. Does anybody else have any input before I take the front tires off again and drop the suspension to tighten them that way?

To me this seems crazy. By tightening them another 3/4", it seems like I am lowering the strut travel capability. Do you really have to tighten the OME struts 1+" into the threads to keep them from clanking? Thanks in advance to those who answer.

Gymkata 09-17-2011 09:14 PM

Re: OME front strut question
 
2 Attachment(s)
Here are a few pics. I tried tightening the nut from the top...still a gap between the strut and the boot, or whatever that rubber piece is called.

jlewissystem 09-18-2011 10:30 AM

Re: OME front strut question
 
Check my post about the center bolt - i had to crank her down :)

http://jeepgarage.org/showthread.php...890#post481890

Anything else clunking might be front sway not being centered.

Gymkata 09-18-2011 11:34 AM

Re: OME front strut question
 
Thanks. I assume you just tighten till it is really tight? What will keep this from happening again under suspension compression?

jlewissystem 09-18-2011 11:42 AM

Re: OME front strut question
 
Yeah, I just tightened it until really tight as I didn't see any specs. I'm not sure about any fallout from full compression, I wouldn't expect any further issues unless it's something else.

Gymkata 09-18-2011 04:38 PM

Re: OME front strut question
 
Alright, I'm going to finish this thing. It annoys me that the suspension came without any instructions. It seems pretty obvious to me that OME should include instructions that show how far the struts need to be tightened, especially considering how much of a PIA it is to tighten them further.

bradley4kc 09-18-2011 05:13 PM

Re: OME front strut question
 
I know this may not help as you already have the strut in the rig - but- I saw a video of a guy changing front coilover struts and he suggested letting off the spring compressors slightly once you get the top plate (or strut mount) on and the nut threaded a little ways when putting the new strut back together. This gives the nut something to grab against when tightening it back down all the way.
I have to say I am learning as I read everything I can find about this mod. I got my front springs the other day and the rest of my OME HD kit is in shipping. Hope all your xtra noise and movement is eliminated.

Gymkata 09-18-2011 07:57 PM

Re: OME front strut question
 
Yes, all the noise/clanking is now gone...once again I would like to reiterate "What a PIA". I tightened both front strut bolts until 3/4" of thread on the struts were showing. This seems to be enough tightening eliminate all clanking.

antsjeep 09-19-2011 11:42 AM

Re: OME front strut question
 
when i had the entire front strut/spring assembly out of my jeep i said to myself i should take a measurement of the same spot your talking about. I have suspension experience from my previous two cars and friends as well... and i knew this part had to done correctly before re-installing the entire assembly. I don't know how the hell you were able to do it based on the pictured you posted, but kudos to you! :D

I'm glad to hear you got it taking care of.

Gymkata 09-23-2011 07:14 AM

Re: OME front strut question
 
The picture I posted did not get it taken care of. I had to take the tires off again and drop the strut enough to get a hold of the top of the strut and the strut bolt at the same time.

My new frustration is that at first I thought 3/4" of thread showing was tight enough not to make noise, but I was wrong. Now instead of loud popping, there is minor clicking. How far down do these things really need to be tightened?

Maybe I messed something up on the install. Obviously the strut bolt keeps the strut from coming down through the plate holding the springs during wheel drop, but what keeps the top of the strut from continuing up into the engine bay farther (and clanking/popping) during wheel compression into the wheel well? Maybe that is where I went wrong...is there something that is supposed to secure the strut on the bottom of the plate holding the springs on top? Sorry if I'm confusing, I don't know all of the technical nomenclature.

NHWK05 09-25-2011 10:13 AM

Re: OME front strut question
 
I had a similar issues when installing my bilstein struts. They wont move at all under any kind of compression because there is a shoulder on that stud under the threads that will seat up tight to the bottom of the upper strut mount. Once that nut is completely tight it cant move. Clunks should go away after, at least mine did.

Gymkata 09-25-2011 12:54 PM

Re: OME front strut question
 
Thanks for the response. I was looking at the stock struts yesterday and came to the same conclusion. I just need to get in there again and tighten till they won't tighten any more.


All times are GMT -5. The time now is 12:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community