Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Anyone ever have a sentry key/engine immobilization problem? (http://www.jeepgarage.org/f181/anyone-ever-have-a-sentry-key-engine-immobilization-problem-28809.html)

nick.jeff 09-20-2011 09:37 PM

Anyone ever have a sentry key/engine immobilization problem?
 
So I got off work earlier tonight, went out to unlock the the WK with the fob, no response. No flashing lights, no doors unlocked, nothing. So I walked over to Walgreens assuming the fob battery was dead and was lucky enough to find a battery for the fob. Installed it, came back, still nothing. So knowing the alarm would go off, I unlocked the driver door with the key and started it, assuming the alarm would disengage. Everything fired up, but the alarm (factory that is) kept going off and then the engine cut off after 3 seconds. Tried starting again, same result. I read in the manual that this is a function of the "sentry key immobilizer system" or something...meaning that the security system of the vehicle is assuming someone is trying to start it with a non-programmed key, so it pre-emptively cuts off the engine.

About an hour ago, I went out back to the WK and disconnected the negative terminal on the battery, let it sit for 10 mins. Reconnected, and everything was working properly again. Started up, didn't cut off, and I am able to engage/disengage/lock/unlock without any apparent problems. I'm hoping this is just a fluke and the sentry key/module got out of sync as the tow truck was on its way to come take it to the dealership where I'm sure the bill would no less than a couple hundred just to figure out what's wrong had disconnecting the battery not solved it.

Anyone else ever experience anything similar?


All times are GMT -5. The time now is 05:01 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community