Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Transmission Hesitation (05 5.7) (http://www.jeepgarage.org/f5/transmission-hesitation-05-5-7-a-29528.html)

HemiHipp 10-09-2011 11:11 PM

Transmission Hesitation (05 5.7)
 
I have an 05 Hemi. Often (not always), after starting the car, when I put the car in Reverse or Drive, the transmission hesitates to fully engage. Sometimes it does not hesitate and acts completely normal. Other times, the transmission doesn't engage at all. It's very troubling... Anyone have any experience with this?

Coincidentally, I am taking my jeep into get it's 90K mile checkup this week. So, they will be taking care of the scheduled transmission service. Do any of you with experience have any recommendations/insights before I take her into the dealership?

Thanks!

Scottina06 10-09-2011 11:38 PM

Re: Transmission Hesitation (05 5.7)
 
just overfill the tranny fluid just a hair......BUT this is pretty normal

oldgeezer 10-10-2011 11:50 AM

Re: Transmission Hesitation (05 5.7)
 
I have the same year jeep and motor as yourself. Here is some information from the owner's manual;
"NOTE:
If the vehicle has not been driven in several
days, the first few seconds of operation after shifting the
transmission into gear may seem sluggish. This is due to
the fluid partially draining from the torque converter into
the transmission. This condition is normal and will not
cause damage to the transmission. The torque converter
will refill within five seconds of shifting from Park into

any other gear position."
Might be a possible explanation?

mjl2610 10-10-2011 12:29 PM

Re: Transmission Hesitation (05 5.7)
 
I had a very similar issue, however, mine was due to a problem with the return filter. This TSB may help.
http://www.wkjeeps.com/tsb/tsb_wk_2101505.pdf

Djsal5 10-11-2011 08:19 AM

Re: Transmission Hesitation (05 5.7)
 
i noticed as well when i start my jeep i let it warm up and come out of the high idle when i start it so i let it warm up for about a min or two

hazards280 10-11-2011 09:29 PM

Re: Transmission Hesitation (05 5.7)
 
I've had this exact problem lately as well.

05HEMI 10-11-2011 10:22 PM

Re: Transmission Hesitation (05 5.7)
 
I also have the same problem. And I also had my return filter split right down the side but that has been changed and I still have the same problem with the hesitation when first starting in the morning I really hope that it is the torque converter and not the tranny.

NHWK05 10-12-2011 09:18 AM

Re: Transmission Hesitation (05 5.7)
 
I have the same issue with my 05 4.7> i just give it a second to fill/warm up lol and its fine. Annoying when in a rush but oh well. Its part of owning a WK. Stalling at stops is also another transmission related issues that wks have. Usually caused by fluid being too low which causes a lack in pressure. Just slightly over filling the trans fixes the problem. This also happens alot after transmission service.

viking757 10-12-2011 10:28 AM

Re: Transmission Hesitation (05 5.7)
 
Quote:

Originally Posted by NHWK05 (Post 497828)
Stalling at stops is also another transmission related issues that wks have. Usually caused by fluid being too low which causes a lack in pressure. Just slightly over filling the trans fixes the problem. This also happens alot after transmission service.

A split in the internal filter may cause that problem too. It did to mine

HemiHipp 10-16-2011 12:38 AM

Re: Transmission Hesitation (05 5.7)
 
Thx for the replies. I had the tranny serviced - fluids changed etc. I haven't noticed any hesitation when starting the car since. I was glad to hear that it is somewhat normal and that it is not detrimental to the tranny. Now, when dropping the shifter down to Drive, it feels a bit smoother too.


All times are GMT -5. The time now is 12:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community