Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Performance Modifications (http://www.jeepgarage.org/f6/)
-   -   Totally over my 180 tstat (http://www.jeepgarage.org/f6/totally-over-my-180-tstat-29890.html)

JeepCoop 10-19-2011 11:13 AM

Totally over my 180 tstat
 
So over this thing. All it does is blow coolant all over my shizzie. Why?! I notice when driving in hotter weather my temp runs close to the mid line.

Also, when romping now I have to shut my AC off at times cuz its over the mid line. I'm at 63,xxx so maybe I could use a coolant flush but still, lame.

Can someone please tell me why you all use the 180 tstat apposed to the stock one, and if it's really gonna change anything if I go back to stock?!

Thanks guys,
-Greg

http://img.photobucket.com/albums/v6...c/cf61d39d.jpg

http://img.photobucket.com/albums/v6...c/d70c1577.jpg

mpg2012 10-19-2011 11:30 AM

Re: Totally over my 180 tstat
 
Did you bleed the air out of the system, after replacing the thermostat and refilling the coolant? There is a bleeder screw where the other radiator hose connects to to the engine.

JeepCoop 10-19-2011 11:56 AM

Quote:

Originally Posted by mpg2012 (Post 501009)
Did you bleed the air out of the system, after replacing the thermostat and refilling the coolant? There is a bleeder screw where the other radiator hose connects to to the engine.

Hmmm no I didn't. Would that help a lot?! It's still runs midline a lot, though and that scares me

mpg2012 10-19-2011 11:59 AM

Re: Totally over my 180 tstat
 
Well if there is air in the system, it will cause it to run hotter than normal and possibly push coolant out of the overflow. Mine is at the tint shop right now, let me see what I can do about finding a picture of the location of the bleeder.....

JeepCoop 10-19-2011 01:11 PM

Cool thanks, I really appreciate it!!

JeepCoop 10-21-2011 07:29 PM

Ever get that pic?! ;)

mpg2012 10-22-2011 07:09 AM

Re: Totally over my 180 tstat
 
Sorry man, phone is messed up and I can'y upload any photos. It looks like an allen head screw in the housing where the radiator hose connects right next to the alternator. Just unscrew the plug and wait until you don't see any air bubbles coming out and only straight coolant.

JeepCoop 10-22-2011 09:46 AM

K cool thanks I'll check it out in a bit

blackpepper 10-22-2011 02:44 PM

Re: Totally over my 180 tstat
 
Greg when you check it out take a picture because my engine looks like you're engine I would appreciate a solution.

ChrisWk 10-22-2011 02:57 PM

Re: Totally over my 180 tstat
 
I had that problem with it spraying I got a new coolant pressure cap it fixed the problem. I had 180 tsat for a year then put the stock one back in. I felt little differ in the two tsat. I still have oem one in. But get a pressure cap.

JeepCoop 10-22-2011 03:37 PM

Quote:

Originally Posted by mpg2012 (Post 502263)
Sorry man, phone is messed up and I can'y upload any photos. It looks like an allen head screw in the housing where the radiator hose connects right next to the alternator. Just unscrew the plug and wait until you don't see any air bubbles coming out and only straight coolant.

Not seeing it. This for the 5.7?

dandankler 10-24-2011 11:09 AM

Re: Totally over my 180 tstat
 
mine also has the same problem but with the OE t stat .....its done it since i bought it wtf.....


All times are GMT -5. The time now is 09:19 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community