Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Help! Grand Cherokee Orvis 1999 4.0 Problem? (http://www.jeepgarage.org/f203/help-grand-cherokee-orvis-1999-4-0-problem-29923.html)

Bob7 10-20-2011 05:48 AM

Help! Grand Cherokee Orvis 1999 4.0 Problem?
 
Hi just bought my Jeep and been loving it. Drove it this morning and it just lost power in middle of road. Couldn't start it, so put hazard lights on and called RAC Recovery. He charged up battery and car is going. He checked battery condition - good. Alternator good. Had petrol in it! He couldn't come up with reason for loss of power. Any ideas?

JMLoughrey 10-20-2011 09:52 PM

Re: Help! Grand Cherokee Orvis 1999 4.0 Problem?
 
Check your harnesses. Make sure everything is tight.

I remember something about there being an issue with one of the harnesses that runs along the passenger side of the hood. I could be wrong though.

Hemi05WK 10-20-2011 10:13 PM

Re: Help! Grand Cherokee Orvis 1999 4.0 Problem?
 
Quote:

Originally Posted by JMLoughrey (Post 501739)
Check your harnesses. Make sure everything is tight.

I remember something about there being an issue with one of the harnesses that runs along the passenger side of the hood. I could be wrong though.


Ground Strap

Frango100 10-21-2011 05:11 AM

Re: Help! Grand Cherokee Orvis 1999 4.0 Problem?
 
There seems to be a cable loom which passes at the back side of the engine and which could be touching the engine and have a shaved through wire, causing a short once in a while.
I also heard of the PCM housing screws which could be too long and after time cause a short inside the PCM. Shorter screws did solve this problem.


All times are GMT -5. The time now is 08:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community