Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   really getting mad with xenon (http://www.jeepgarage.org/f181/really-getting-mad-with-xenon-30209.html)

filo8818 10-27-2011 11:01 AM

really getting mad with xenon
 
hi guy, i have a jeep commander 2007 that is the the same of jeep grand cherokee and i have this terrible probhle.
i bought the xenon kit, i install it and the light was flickering so much so thanks to the forum i bought the relay harness but now one of the two light turn on 15 second after the other.
i already changed the bulb and the rest but to work fine i have to turn the car on, turn the position light on and afte 10-15 sec turn on the low beam light otherwise one doesnt wanna turn on....
i hope u can help because i really dont know what to do..
but the relay harness should be one for the pair of light or one each light?
thanks again...

mhardine 10-27-2011 12:13 PM

Re: really getting mad with xenon
 
It should be one relay harness to 2 ligths i.e. Both bulbs of the low beam.
What is the amps of the fuse in the relay?
Are you using a 35w hid kit or a 55w hid kit?

filo8818 10-27-2011 12:39 PM

Re: really getting mad with xenon
 
ok. gonna write here what i have :

BALLAST:
bulbtype 35W
V in 9-12V
V norm 3.2A
I In max 35W Norm.
T case -40 cel-+150 cel

RELAY:
40A/12VDC
H4458-12VDC

FUSE: 25A

I have to change some part?
Thanks so much...:)

SvenskaJeepGuy 10-27-2011 12:45 PM

Re: really getting mad with xenon
 
you should have two relays, one for each light. check all of your connections. you can also try swapping the ballasts with each other to see if you damaged one of them

filo8818 10-27-2011 01:03 PM

Re: really getting mad with xenon
 
i already try to swap it and same problem so i guess is something linked with realy voltage.
My lamp are like this: one relay that run from battery to the left lamp and from the relay run to the right lamp...how i can put one realty per light?
but the fuse it too strong for u? or the voltage of the realy'
thanks a lot

05WK 10-27-2011 02:31 PM

Re: really getting mad with xenon
 
It should go [battery]-(relay)<both lights.

Basically the power should go to the relay before spreading to the lights.

If they're wired how you say, that may be the cause for the delay.

filo8818 10-27-2011 06:37 PM

Re: really getting mad with xenon
 
yes my configuration is like this: BATTERY-->FUSE 25A--> JUST ONE RELAY<ballast 1 & ballast 2

i cannot put 1 relay per light or yes?
It need just 10-15 sec and if i just switch the car off and i turn it on again maybe is also immediately..is like the relay needs a little to accumulate energy.....i dont know how to figure it out..

thankkkkks

filo8818 10-27-2011 06:38 PM

Re: really getting mad with xenon
 
sorry guy if i llok like stupid but how many relay did u have on your hid???

SvenskaJeepGuy 10-27-2011 09:24 PM

Re: really getting mad with xenon
 
they sell the relays like you have which are not recommended and then they make individual relays for each light. you should have a set on those. if your relay goes, so do both of your lights.

filo8818 10-28-2011 02:55 AM

Re: really getting mad with xenon
 
so i post u a pic of my relay..i bought in on ebay but the sand me two of it so i can take a pic to show if is correct...the one i have on my car is exactly the same of this...
http://imageshack.us/photo/my-images/818/photo2th.jpg/

its good? thanks

filo8818 10-28-2011 02:56 AM

Re: really getting mad with xenon
 
http://img818.imageshack.us/img818/8430/photo2th.jpg

Uploaded with ImageShack.us

mhardine 10-28-2011 06:59 AM

Re: really getting mad with xenon
 
try going up to a 30 amp fuse that what i use in mine


All times are GMT -5. The time now is 12:45 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community