Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2010 - Hatch Struts Bad at 19350 miles? (http://www.jeepgarage.org/f181/2010-hatch-struts-bad-at-19350-miles-30242.html)

RiverCityOffroad 10-27-2011 08:48 PM

2010 - Hatch Struts Bad at 19350 miles?
 
Is this common?

My wife got just about knocked out loading some flowers this morning. Lmao!!

Ok it's not funny!

The struts have been fine, no extreme use or long holds.

Thoughts? I searched here and google.

SvenskaJeepGuy 10-27-2011 09:11 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Quote:

Originally Posted by MarcusRTJ (Post 505166)
Is this common?

My wife got just about knocked out loading some flowers this morning. Lmao!!

Ok it's not funny!

The struts have been fine, no extreme use or long holds.

Thoughts? I searched here and google.

was it cold out for you today? my stock struts used to suck when it was cold. i replaced them with strongarms from advance auto and they work great

RiverCityOffroad 10-27-2011 09:43 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Interesting! It wasn't cold out this morning but it is tonight. Well...cold for Texas. Ha ha.

Uncle Paul 10-27-2011 09:48 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
The cooler it gets, the weaker the struts get.

It is not the miles on the vehicle, but the age, and number of times opened and closed.

Think new ones are less than $20 at the dealership.

When mine got weak, I just replaced one. That made it just right for the support. When the struts were new, they make the hatch very difficult to pull down. Just replacing one strut was perfect.

Same thing with the flipper hatch

SvenskaJeepGuy 10-27-2011 09:56 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Quote:

Originally Posted by MarcusRTJ (Post 505209)
Interesting! It wasn't cold out this morning but it is tonight. Well...cold for Texas. Ha ha.

well it is snowing here so :madder: HAHA

SvenskaJeepGuy 10-27-2011 09:57 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
i would just replace them with strongarms, they seem to be highly recomended online and i have had no problems with mine. i installed them in 2009 and use them daily.

Crashtown 10-27-2011 10:53 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
The hatch on my 05' could use some softening. Every time I close it, I feel like I'm spinning the gigantic wheel on the Price is Right. I want to replace the lift shocks on the flipper glass. It holds up fine, but apparently, it's supposed to raise on its own. It's never done that since I bought it 2 years ago, so I didn't know any better.

RiverCityOffroad 10-27-2011 11:33 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Good info here guys, I do appreciate it!

Sorry you're dealin with snow, I've got some friends up there and the Facebook posts are hilarious!

SvenskaJeepGuy 10-28-2011 01:37 AM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Quote:

Originally Posted by Crashtown (Post 505251)
The hatch on my 05' could use some softening. Every time I close it, I feel like I'm spinning the gigantic wheel on the Price is Right. I want to replace the lift shocks on the flipper glass. It holds up fine, but apparently, it's supposed to raise on its own. It's never done that since I bought it 2 years ago, so I didn't know any better.

i was the same as you, i never knew that the glass opened on its own until i replaced the struts

99formulam6 11-08-2011 03:30 PM

Re: 2010 - Hatch Struts Bad at 19350 miles?
 
Quote:

Originally Posted by Crashtown (Post 505251)
The hatch on my 05' could use some softening. Every time I close it, I feel like I'm spinning the gigantic wheel on the Price is Right. I want to replace the lift shocks on the flipper glass. It holds up fine, but apparently, it's supposed to raise on its own. It's never done that since I bought it 2 years ago, so I didn't know any better.

I have almost clipped my wife in the head a few times when I open the glass with the remote on our XK. It flys open like no one business. My WK doesnt open up though, but it holds up fine.


All times are GMT -5. The time now is 01:23 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community