Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   99 4.0 o2 sensor problems (http://www.jeepgarage.org/f77/99-4-0-o2-sensor-problems-30391.html)

jsouza111 10-31-2011 03:44 PM

99 4.0 o2 sensor problems
 
so the code came up as PO161 O2 Sensor Heater Circuit (Bank 2 Sensor 2). i just dont know which one to replace, but i came upon this pic

http://www.zombiecrisis.org/stuff/engine.jpg

but the only sensors i can see are 2/1 and 1/1
AND wat makes it confusing is that my door says my truck is federal.

HELP GUYS!!!!

which sensor do i replace :confused:

01grand 10-31-2011 04:18 PM

Re: 99 4.0 o2 sensor problems
 
If your jeep is indeed federal only (not california) you will have only 1 main cat instead of that plus 2 mini-cats. On federal there are 2 O2 sensors, 1 each before and after the cat. On California there is 1 before and after each mini cat. So, this code is kind of confusing if your truck is only federal. My guess is it would be the after cat sensor.

jsouza111 10-31-2011 04:48 PM

Re: 99 4.0 o2 sensor problems
 
yae im confused to. heres this pic that confuses me even more.

http://www.wjjeeps.com/oxygen_40.jpg

the pic that shows federal i dont see either of those o2 sensors. the only sensors i can see are the two i said before ( 2/1 and 1/1 ) which are under the California picture. my guess is thats its the 2/1 but the code said bank 2 sensor 2 which means 2/2.


All times are GMT -5. The time now is 03:49 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community