Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Code p0520-oil sensor (http://www.jeepgarage.org/f181/code-p0520-oil-sensor-30852.html)

4.whoa 11-08-2011 11:25 PM

Code p0520-oil sensor
 
Well, just got this code.:mad: I change my own oil.I ALWAYS use synthetic 5w20.I have just about 2k on this change,last one had about 3600 mi. I changed it early as I was leaving on a trip(usually go 4k w/synthetic) I used castrol this time and added Z-max as well (i've used it before and didnt have any issues) its been running fine,just had the light on this morning.I checked the oil level and its right in the middle of the hatch marks.I hooked up my DS and monitered it, but it shows voltage, not psi :confused: @ idle it was 2.0-2.5v and driving was 3.3-4.1v i have no idea what that equates to. I cleared it,and after about 30 min of in town driving its back on :mad: :mad: i'm NOWHERE near home and have about 1800 mi till i am.since the oil symbol light isnt coming on,is there a problem with driving it? it doesnt have any abnormal sounds...
Please help!

Scottina06 11-09-2011 12:00 AM

Re: Code p0520-oil sensor
 
P0520-ENGINE OIL PRESSURE SENSOR CIRCUIT


Possible Causes
(G6) ENGINE OIL PRESSURE SENSOR SIGNAL CIRCUIT SHORTED TO VOLTAGE
RESISTANCE IN THE (G6) ENGINE OIL PRESSURE SENSOR SIGNAL CIRCUIT
(G6) ENGINE OIL PRESSURE SENSOR SIGNAL CIRCUIT SHORTED TO GROUND
RESISTANCE IN THE (F855) 5-VOLT SUPPLY CIRCUIT
(F855) 5-VOLT SUPPLY CIRCUIT SHORTED TO GROUND
RESISTANCE IN THE (K900) SENSOR GROUND CIRCUIT
ENGINE OIL PRESSURE SENSOR
POWERTRAIN CONTROL MODULE (PCM)

probably thee oil pressure sensor switch. Its right below the oil filter. Make sure its not loose or came unplugged. Could be bad too. About $60 at dealer.

http://repairguide.autozone.com/znet...3f802049a5.gif

4.whoa 11-09-2011 12:15 AM

Re: Code p0520-oil sensor
 
Thanks alot, :) I'll check that in the morning.

Scottina06 11-09-2011 12:25 AM

Re: Code p0520-oil sensor
 
auto parts stores have them too...much cheaper...no idea about quality though

4.whoa 11-10-2011 12:39 AM

Re: Code p0520-oil sensor
 
Well,i tried to pull it out to clean it...... WOW WHAT A P.I.T.A. To get to! I guess the pic is for a 4.7? My hemi was a little different .had to pull the skid plate and it was all i could do to get my hand in there to pull the plug! It needs to be removed with a deep 1-1/16" socket,which i didnt take on my trip,so i wiped the connections the best i could, added a qt of oil, and it hasnt popped back up yet.about 5 hrs & 200 mi so far (damn traffic )

While i was under it,I found my water pump is starting to leak slightly :(

2005JGC 11-10-2011 03:37 AM

Re: Code p0520-oil sensor
 
My guess would be a 3.7l actually as that is a skinny filter not a fatty 090 filter on the 4.7l ;)

Sure does sound like a sender to me too...

lastly, stupid water pumps.


All times are GMT -5. The time now is 11:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community