Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Diesel Powered WK Grand Cherokee (http://www.jeepgarage.org/f184/)
-   -   hello (http://www.jeepgarage.org/f184/hello-30975.html)

marakchi 11-11-2011 03:54 PM

hello
 
Hello
I am the newest member to your forum, my Name is marakchi, i have 2009 Jeep Grand Cherokee, CRD, overland, grey color,

i am taking the opportunity in my first post, to ask this question, the heating meter went up, and i didn't see any sign, i opeend the hood and checked the radiator and there was no cooling water, i filled it drove for half an hour, re checked and there was no colling left, i have just filled it again, and i will check in the morning to see if level went down.

can you tell me what's the problem may be?

thanks

regards
marakchi

52233 11-14-2011 03:05 PM

Re: hello
 
check to make sure you use the right fluid, must be approved. After you filled, check for leaks on the driveway or road, loose hose clamp?

swarmer 06-26-2012 07:02 AM

Re: hello
 
There's either a hole in your cooling system or engine :-( Good luck.

TRUCKDIVA 06-26-2012 08:19 AM

Re: hello
 
Welcome to the thread.

Madanio24 07-01-2012 06:55 PM

Re: hello
 
Your leaking from somewhere. Check if all lines are completley sealed especially the valve at the bottom of the radiator.


All times are GMT -5. The time now is 05:29 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community