Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   O2 Sensors (http://www.jeepgarage.org/f5/o2-sensors-31290.html)

Billyb.cpt 11-18-2011 07:29 PM

O2 Sensors
 
Ok so I've changed the EGR Valve, cleaned the PCV valve, cleaned the throttle body, installed the 392 IAT sensor (thanks robpp), installed K&N drop in filter, installed Bilsteins all around (which help considerably with reduced nose dive coming to a complete stop and increased my braking performance as well) and I'm about to install a new MAP sensor. Yet with all of this done I'm still getting bad MPGs, 9-10.5/city, 12-14/highway. So the O2 sensors are next. Question is: Has anyone replaced them themselves and does it help improve MPGs even by just 1-3MPG? If so is there a How-to and is it alright for now to just replace the upstream sensors first? I picked up the NGK 21360 upstream sensors today and plan on doing this this weekend. Any help will be greatly appreciated!

jeepgcoman 11-20-2011 12:48 AM

Re: O2 Sensors
 
How many miles on your ride? I had one sensor become "lazy" at around 60K. I ended up changing all 4 sensors, but not without issue. I subsequently did this thread on the how's, why's and gee whiz facts on O2 sensors:

http://jeepgarage.org/showthread.php?t=20300

Hope it helps you out. Also, to answer your question.....if you've done all the other "normal" things and the mileage is still bad, the O2's could very well be the problem. Also, could still be something else, but for $120 or so, you can eliminate them for sure.

Billyb.cpt 11-22-2011 01:56 PM

Re: O2 Sensors
 
Quote:

Originally Posted by jeepgcoman (Post 518484)
How many miles on your ride? I had one sensor become "lazy" at around 60K. I ended up changing all 4 sensors, but not without issue. I subsequently did this thread on the how's, why's and gee whiz facts on O2 sensors:

http://jeepgarage.org/showthread.php?t=20300

Hope it helps you out. Also, to answer your question.....if you've done all the other "normal" things and the mileage is still bad, the O2's could very well be the problem. Also, could still be something else, but for $120 or so, you can eliminate them for sure.

How did you replace them? Did a dealer do it? I'd really like to try it myself as I have all 4 sensors (NGK). But I was under there and located all 4 and it's really tight under there and my arms aren't exactly huge but they aren't small either.

jeepgcoman 11-22-2011 05:49 PM

Re: O2 Sensors
 
Yes, I replaced them but, for sure, my system is different from yours. I have custom tubular headers, and it's not as bad as the stock setup. You will for sure need and O2 sensor socket to get them out. Be careful not to contaminate the new ones on install and also make sure they're completely plugged in. Are you sure yours are NGK and not NTK? NTK is a division of NGK and they make the stock ones for the Chrysler products. If you saw my thread, you'll see the problem I had with the Bosch ones.

Good luck and let us know how it goes, especially if the mileage/performance improves.

Billyb.cpt 11-23-2011 11:04 PM

Re: O2 Sensors
 
Haha yes sorry I actually have the NTK ones that you recommended in that very informative thread and for that thank you! I will attempt to do this sometime this weekend if time is available. My schedule changes all of the time so we'll see.....

jeepgcoman 11-24-2011 07:11 PM

Re: O2 Sensors
 
Please let us know how it goes for you.

Billyb.cpt 11-25-2011 12:48 PM

Re: O2 Sensors
 
I haven't had a chance yet to change them but I did go to Autozone to use the code reader and monitor my 02 sensor voltages. The upstream sensors (1/1 and 2/1) were jumping all over the place hardly reaching 450mV as you stated and the downstream sensors (2/1 and 2/2) are relatively constant at 0.860 each. Is that number to high? Also I noticed my barometric pressure is at 30.1hg (I'm at sea level) and on start up my MAP Sensor pressure is only registering 8.6 Hg, shouldn't that number jump and get close to 30.1 once I open the throttle? The only reason I'm asking about that is because lately the Jeep feels really heavy upon acceleration almost like it's starving for air.

jeepgcoman 11-25-2011 11:20 PM

Re: O2 Sensors
 
Billy, how bad was the backside of the throttle body butterfly when you cleaned it? Was there any puddling in the intake plenum? It is possible that the MAP Sensor is contaminated. I changed mine just because. Since you're thinking of doing the same, go for it. The part is only about $25. How many miles are on yours?

Your front O2's sound like they are bad. They should be "jumping" all over the place, but they should cycle above and below (crosscounts) the so-called midpoint of .450 mv. If they're staying below .450 mv (approximately 14.7:1 A/F ratio), they are sending a lean signal to the PCM and I suspect the PCM is telling the fuel injectors to keep adding fuel until it gets to the proper mixture. Only problem is that it isn't ever getting there if there are no crosscounts and the readings never get above .450 mv.

Your rear sensors sound like they're still working alright, as long as they stay above .450 mv (mine usually run ~.700-.800 mv) and there are NO crosscounts. I would change them too though, as if this has been going on for awhile, they could become contaminated. Long term rich mixture could also take out your catalytic converters. IMO, it's a good thing you're doing this.

Keep us posted.

jmc2004 04-22-2012 02:40 PM

Re: O2 Sensors
 
Anyone replaced the downstream o2 sensor on bank 2? I have looked at it and have no clue as to how to get to plug or get a wrench in for the sensor itself.

Bleeding Blue 04-22-2012 03:07 PM

Re: O2 Sensors
 
A shop did mine, but they had to reach through the wheel well....they said it was a huge PIA

Billyb.cpt 04-23-2012 06:26 PM

Re: O2 Sensors
 
Well an O2 socket wrench from Autozone will unbolt it but to reach the plug is a huge pain in the ass! I still have yet to replace it but I did replace the other 3 on my own.


All times are GMT -5. The time now is 06:13 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community