Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (
-   Liberty-KJ and KK (
-   -   Problem getting an FLCAN bypass on a Viper 5701 to read my key (

Wrathwielder 11-20-2011 02:49 AM

Problem getting an FLCAN bypass on a Viper 5701 to read my key
Hi all!

I need help programming an Audiovox FLCAN FLC-AL(DL)-CH5 bypass on my Viper 5701 alarm/remote start.
Try as I might, it’s just NOT acting like the instructions say it should and I’m unable to get it to “read” my key.

Here’s the skinny – bear with me as I’m long-winded:

I have a Jeep Liberty 2011 with a Viper 5701.
The 5701 was installed by a dealer and it has been functioning great.
I wanted more range, so I purchased the antenna and LCD remote that come with the Viper 5901 – DEI said that would work with the 5701.
I purchased a Bitwriter and recorded every single setting available just in case I lost the settings when I paired the new remote/antenna combo.
Swapped the antenna and paired the new remote – no probs so far.
All was well for every function EXCEPT Remote Start. When I tried that I’d just get a remote start error on the keyfob.
There were NO parking light flashes to indicate errors.
I decided the bypass must need to be reprogrammed to my factory key again.
I reset the FLCAN unit to factory defaults per the instructions I got from Audiovox – it’s the FLC-AL(DL)-CH5 unit (unplug cables, hold programming button in while plugging the 4-wire cable back in – release the button, etc.)

Now the annoying part…

The instructions then say that to reprogram the unit to my key I need to:
1) Press and release the programming button (on the FLCAN) to select the installation mode – 1 flash=DATA MODE, 2 flashes=STANDARD HARDWIRED MODE and then HOLDING the button to choose that option…NO CAN DO. Pressing the programming button does nothing – LED stays off. I have a feeling that there are possibly Jeep-specific hoops I need to jump through BEFORE I press the button to choose a mode – like open door, close door, pat head, rub stomach, etc.
2) I tried HOLDING the button in. This causes the LED to flash green once (delay) then twice (delay) then 3 times,… until it gets up to like 9 or something and then it starts over at 1. If I release the button the LED goes out and if I press and hold it again it starts the same routine over.
3) I’ve tried doing this with the door open, closed, key in, key out, key ON, key OFF…no go. I actually got it to darn near act like the instructions by opening the door and leaving it open, holding the button down for like 2 minutes until the LED flashed RED once over and over. I hit the button again and got 2 RED flashes. I took this to be hardwired mode. I pressed and held the button again and got solid green which the instructions indicate should be happening. I put the key in and turn it to ON and the LED just stays solid green even though it’s supposed to switch to RED and then flash green rapidly. I don’t know exactly what I did to get this all the happen, but I managed to stumble across it a couple more times and tried the whole routine with both programming modes (not sure which I want anyways – I figure hardwired mode…?)

Anyways, sorry to draw this out – you get the picture… J

What am I missing?
I’m hoping there’s someone out there that has used one of these FLCAN units that can tell me what’s in the secret sauce so I don’t have to break down and bring it back to the installer and deal with that whole mess…

Thanks everyone!


JMLoughrey 12-02-2011 08:29 AM

Re: Problem getting an FLCAN bypass on a Viper 5701 to read my key
Hey, just found your thread, it sounds like the FLCAN didnt fully reset itself during your reset procedure, the LED should flash red multiple times after your do the reset procedure. Then plug the harness back in while holding the prog button. If done properly the LED should flash green and a slow pace of one flash, pause, one flash, pause ETC.

you'll hit the program buttom once, the led should then flash green in the patter of 2 flash, pause, 2 flash pause ETC, then push and hold the prog button and the LED will go solid green.

A couple other things you can try to diag if it really is the FLCAN is put your key in the ignition and try to remote start it. If it remote starts if def the FLCAN, if it doesnt, there is something else at play.

Feel free to shoot me a PM and i can help walk you through it, i've been installing for 7 years professionaly and have more then my share of experience with the FLCAN.

JMLoughrey 12-02-2011 08:31 AM

Re: Problem getting an FLCAN bypass on a Viper 5701 to read my key
That link should also give you some insight.

Wrathwielder 12-02-2011 02:43 PM

Re: Problem getting an FLCAN bypass on a Viper 5701 to read my key
Thanks for the response!

A few days ago it suddently dawned on me that the "missing first step" to learning the key could be the FLCAN reset itself. At almost the same time someone in another forum posted the same thing I was thinking, so I gave it a shot and SURE ENOUGH when I finished the FLCAN reset it was left in the mode I needed, to do what you described, and get the key learned! :)

Of course that didn't help my whole remote start error problem :(

I was at wits end, and decided I had no choice but to go to Best Buy and tell them it wasn't working, and explain how I had replaced the remote and antenna myself and that they should fix it for free...but then I said a quick prayer and SUDDENLY I had a thought...

I had set the remote start pulses to 2 back when I had the original 5701 (non-LCD) remote so it would be harder to accidentally remote start the truck.
When I swapped the antenna and remote for the 5901 versions, I also set the pulses to 2.

I experimented...
I hit the remote start button once - and got the error. I hit it twice and got the SAME error. I hit it 3 times - same thing.
This was strange as you'd expect a different error from hitting it TOO FEW times than I would get after hitting it the correct number of times and having a true remote start issue at the 5701 or FLCAN (cuz I was never hearing a click or seeing any parking-light error flashes)...

I had an idea...I then hit it FOUR TIMES the truck strarted!!!

STUPID STUPID STUPID! The entire problem from the GET-GO has been that the 5701 wasn't accepting the DOUBLE-PRESS because of a delay in how the new LCD remote sends the pulses to the 5701!

It just happened that pressing it FOUR times did the trick because after the THIRD press I would see another icon (receive?) blink and the FOURTH press just happened to coincide with that little icon and PRESTO the 5701 took that as the 2nd pulse it was waiting for...

Sorry I took such a long-dramatic way to explain it, but it's so darn frustrating that it was so simple! I mean I spent HOURS trying to debug this - wiping out the 5701 3 times, reprogramming the FLCAN numerous times - plugging, unpluggging, relearning remotes - SHEESH!
All I had to do was set the PULSE count to be ONE and it would have worked right out of the chute!

I had this same issue with the original 5701 remote when I needed to send a double-unlock press to open the remaining doors after the driver door unlocked. I was able to send a double-pulse by timing it JUST right, to simulate the double-press on the factory remote (which didn't care about timing - it knew I had hit it once already so any time later if I hit it again it would unlock the rest)
I changed the 5701 to send a DOUBLE-UNLOCK pulse when you pressed UNLOCK, but that didn't work either.
I finally solved it by changing the pulse DURATION to be .4 and that did the trick!

This all leads up my REAL question...
How can I get this fancy new LCD remote to allow me to set the 5701 to require 2 pulses for the remote-start?
It worked fine with the non-LCD 5701 remote, but this new one must be buffering things up before sending or something as I'm only able to get it to work after timing the presses just right - which just happens to work out to 4 when I do it...

I've played with every setting I can find that might relate to this and nothing helps...

The only thing I can think of is that the 5901 is able to handle the LCD remote in a way that the 5701 can't...does that sound plausible?

I'm fine with having it set to start on only 1 press if I have to because I have the keypad set to lock, but the caveat to that is that the remote will NOT lock if you just shut the truck off and then never hit the lock button.
I come home and park in the garage, shut the truck off, and then go into the house leaving the truck unlocked. Because of this the next time I pick up the remote - no matter how long I wait - it will not be locked so the remote start button is, of course, more vulnerable to a single press by accident...

WHEW! That about covers it - any interesting ideas on any of this?

I guess I could sum it up to:

A) Why can't I get a double-pulse sent to the 5701 correctly when I press the button 2 times
B) Why doesn't the LCD remote AUTO-LOCK the keypad when you don't hit the LOCK button after you shut off the truck. I thought it had a 30-60 second "grace" period after turning off the ignition, but it appears it must be a 30-60 sec grace period after hitting the LOCK button I guess.

Thanks SO much for your help! :)


JMLoughrey 12-02-2011 04:57 PM

Re: Problem getting an FLCAN bypass on a Viper 5701 to read my key
ill see what i can dig up tomorrow at work, all my useful info is in my laptop at work.

All times are GMT -5. The time now is 10:14 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community