Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   need help PLEASE!!!! (http://www.jeepgarage.org/f181/need-help-please-31859.html)

jeep5.7 11-30-2011 05:12 PM

need help PLEASE!!!!
 
when i went to replace my plate lights with my new led ones i put them in and no light,so i went to put the stock ones back in and no light??
im thinking fuse but where is it i cant find any info on it

dssilvestri 11-30-2011 08:13 PM

Re: need help PLEASE!!!!
 
flip the LEDs around, theyre polarity sensitive

robpp 11-30-2011 08:18 PM

Quote:

Originally Posted by dssilvestri (Post 525060)
flip the LEDs around, theyre polarity sensitive

Then WHY doesn't his Edison bulb work?

lll2for3lll 11-30-2011 08:24 PM

Re: need help PLEASE!!!!
 
I'm looking now. I can't figure out witch fuses it is. Maybe I'm looking too fast.

lll2for3lll 11-30-2011 08:26 PM

Re: need help PLEASE!!!!
 
Could it be the same fuse as the brake lights?

lll2for3lll 11-30-2011 08:29 PM

Re: need help PLEASE!!!!
 
Try the blue 15 amp fuse under the hood. Fuse #26

dssilvestri 11-30-2011 11:36 PM

Re: need help PLEASE!!!!
 
Quote:

Originally Posted by robpp (Post 525066)
Then WHY doesn't his Edison bulb work?

Maybe something happened to them on the way out.

2005JGC 12-01-2011 02:40 PM

Re: need help PLEASE!!!!
 
Check the socket, maybe stuffing the led bulb into the socket a pin got folded over or something... I would also check my wires to the socket. Do you know for sure it was working before hand (like 100% sure). If you are I would closely inspect everything you touched back there to make sure as my first suggestion, nothing is damaged.

Typically when something worked before you touched something then didnt after, no matter how sure you are that all is ok that is ALWAYS the first place I look.

BigTicket13 12-01-2011 03:17 PM

Re: need help PLEASE!!!!
 
My bet is a fuse. Seems like the mostly explanation.

jeep5.7 12-01-2011 06:29 PM

Re: need help PLEASE!!!!
 
thanks for all your help guys,the problem was when i was putting the 3157 led in taillights i blew the left parking light fuse,so replaced it (cavity 8 under under hood)and all is good now,led plate lights r in and ill put pics once i install the reverse leds,on backorder,ill put up pics of hid fog install led reverse and plate,thanks again


All times are GMT -5. The time now is 05:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community