Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Lube me up...need some help (http://www.jeepgarage.org/f181/lube-me-up-need-some-help-32259.html)

08Hemi 12-08-2011 01:29 PM

Lube me up...need some help
 
Seems that my rear suspension is making some squaks when compressing (ie over speed bumps or uneven pavemnet at slow speeds). Can comeone provide a link to the best lubricant for our rear shocks and the bushings for the sway bars? Also, please enlighen me as to how to properly apply the lube (naughty joke inserted here). That's what she said

Seriously thought, +rep to the first person to link the lube/grease and inform me as to proper application. Thanks JG :thumbsup:

mrtosh 12-08-2011 02:08 PM

Re: Lube me up...need some help
 
When you're rear compresses it puts load on everything; shock eyelet bushings, control arm bushings, trac bar mount bushings, coil springs and their rubber isolators on the perches. More than likely its a squeeky control arm bushing or a shock mount bushing. Do you have aftermarket shocks?

In any case I would use a white lithium grease spray(found at most auto parts stores) and spray the shock eyelets(between the rubber and the jeep mounts) first and see how that works. Then you can go on to the control arms if that doesn't fix the squeek.

mrtosh 12-08-2011 02:11 PM

Re: Lube me up...need some help
 
Also are you sure the squeek isn't coming from inside the jeep behind you? I had a squeek that happened when pulling I'm and out of the driveway and it turned out to be my rear seat latches needed grease. Could try driving over bumps with the rear seats down.

08Hemi 12-09-2011 12:20 PM

Re: Lube me up...need some help
 
Thanks for the quick response mr Tosh!

I do have aftermarket shocks (HD Bilsteins for the WK), stock springs, and SRT8 sways and bwoody sway links (non-srt). I will be doing it this weekend and report back! +rep for you kind sir

And sick sig pic BTW, I love your rig

mrtosh 12-09-2011 01:36 PM

Re: Lube me up...need some help
 
Thanks for the compliments! Now that you mention it I totally spaced on the sway bar. I'm willing to bet that your sway bar bushings are in need of lube.

08Hemi 12-09-2011 03:07 PM

Re: Lube me up...need some help
 
So do I need to detach and lube or can I leave them connected?

mrtosh 12-09-2011 03:41 PM

Re: Lube me up...need some help
 
I would detach and lube for the sway bar brackets. I doubt the end links are making noise.

05wkguy 12-12-2011 12:37 PM

Re: Lube me up...need some help
 
My rear endlinks have to be lubed once a year or they squeak badly. I have the Bwoody ones though. The lithium grease works but can be quite smelly. I use a heavy duty synthetic chassis grease. Or any marine grade grease will work too.


All times are GMT -5. The time now is 01:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community