Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Air conditioning heating problem (http://www.jeepgarage.org/f181/air-conditioning-heating-problem-32931.html)

Blutarsky 12-22-2011 06:06 AM

Air conditioning heating problem
 
Troubles with Euro WH HEMI MY2007 (bought December 2006).

A month ago, heating wouldn't work. No warm heating, even though setting the heater to "HI" and using manual heating (no auto).

Service technician told me it could be due to:
- faulty infrared sensors, although no error from diagnostics
- faulty heating radiator (needs dash removal = $$$$)
- Coolant leakage

As the coolant level was between the MIN and MAX level, the level was refilled up to MAX.

The heating started working again!

However still there's something strange:
- In the first minutes of usage, the air flowing is very hot (HI & manual)
- Once hot enough, switching the temp to 22/24 cools down the air temp
- When switching again to HI (& manual) the air will not get hot anymore...

Facts:
- The coolant level did not change (no leaks)
- As the infrared sensor should be inactive when in manual mode, it shouldn't be taken in account.. correct?

What can I try? Maybe some air somewhere? Or could the heating radiator be defective?


All times are GMT -5. The time now is 04:51 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community