Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Prestone Coolant Causing Water Pump Problems?? (http://www.jeepgarage.org/f181/prestone-coolant-causing-water-pump-problems-33073.html)

jmolli 12-26-2011 12:48 PM

Prestone Coolant Causing Water Pump Problems??
 
replaced the water pump on my 05 3.7L WK about two years ago at 70,000 miles. The bearings had begun to fail and I had a chattering at idle from the pump pulley. I installed a brand new Mopar pump from the dealer. I topped off any coolant lost in changing the pump with a 50/50 mixture of Prestone and distilled water. I probably added about a gallon of the Prestone mix. (Note that I was lazy and didn't drain the coolant, I just pulled the pump and let the coolant spill out into my catch basin).

Now only two years and 35,000 miles later, the new pump is leaking! The bearings seam fine but I am loosing fluid overnight after it cools down. I've never seen anything like it, it only leaks when the outside temp goes below freezing. Once you start it up and get up to operating temp, the leak goes away! It appeared to be leaking past the water pump gasket/seal. I've just installed another new OEM pump and topped off with 50/50 Prestone again.

Now I've noticed that Jeep cautions against mixing "non-hoat" anti-freeze with the OEM "hoat" anti-freeze. My question is did my mixing 50/50 Prestone with the factory coolant, lead to the new pump/gasket failing in just two years??

Does the Prestone attack the rubber water pump gasket/seal?? I'm thinking I should do a coolant flush and re-fill with OEM coolant.


Thanks in advance for your replies.

SvenskaJeepGuy 12-26-2011 02:30 PM

Re: Prestone Coolant Causing Water Pump Problems??
 
that could be the problem, but it is too late for a flush if it is already leaking

psychojeepers 12-25-2012 02:38 PM

Re: Prestone Coolant Causing Water Pump Problems??
 
i am havin the same problem and exact same everything to the problem above and did the same thing with the new seal and filling back up with 50/50 mix...

goflick 12-26-2012 07:30 AM

Re: Prestone Coolant Causing Water Pump Problems??
 
Quote:

Originally Posted by jmolli (Post 540462)
c My question is did my mixing 50/50 Prestone with the factory coolant, lead to the new pump/gasket failing in just two years?

Yes, drain it, flush it and put the correct coolant in and you should be ok.

JeepTechGA 12-26-2012 09:17 AM

Re: Prestone Coolant Causing Water Pump Problems??
 
Highly doubt flushing it will fix anything The bearings are doing the same thing out the wheep hole

goflick 12-26-2012 09:58 AM

Re: Prestone Coolant Causing Water Pump Problems??
 
My bad, you are going to need a change the pump again.

Drew 01-03-2013 03:47 PM

Re: Prestone Coolant Causing Water Pump Problems??
 
Personally I just think the pumps are JUNK. I had my first pump go out, literally blowing coolant all over the road, at 43k (untouched OEM only fluid) and just replaced another 2 weeks ago with just over 75k miles (again, untouched OEM only fluid).
So, I'm on my 3rd OEM pump at just over 75k miles....with OEM fluid.

stashgto 01-03-2013 05:40 PM

Re: Prestone Coolant Causing Water Pump Problems??
 
WOW I was going to ask if I have 100,000 when I should think about changing it. That sounds terrible maybe I'll just change it to stay ahead of the curve. Are there any other brands that maybe better?

dsjr2006 01-05-2013 03:08 PM

Re: Prestone Coolant Causing Water Pump Problems??
 
Our Jeeps require G05 Fluid, not just any off the shelf 50/50. The non-HOAT fluid supposedly causes premature failures.


All times are GMT -5. The time now is 01:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community