Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   In the shop (http://www.jeepgarage.org/f73/in-the-shop-33232.html)

Red G8R 12-29-2011 07:08 PM

In the shop
 
My Jeep is in the shop and has to stay overnight. This morning it was -13 C, remote started the car, scraped off a bit of snow then went in the car and noticed there was no heat blowing. The climate control gauges all read normal on auto, heated seats, steering wheel and rear defrost came on as expected but no fan blowing. I tried restarting the car, went to manual on the climate control and nothing. So I called the dealer and told them I had to come in.

Went back in the car and this time everything started and worked as it should. Heat was blowing etc., but the my air suspension warning came on EVIC, "service immediately". Drove to the dealer and the entire time the air suspension warning is beeping, the Jeep never raised to normal height (was in park mode) and the ride was rougher than normal. At the dealer I noticed the Jeep was way lower than park mode.

So, my air suspension fully failed (22,000 km) and they are still sorting it out. The climate control worked again so they may not find anything. They also said they had a "rapid response" notice on my car and it had to do with some rear bolts that needs replacement. Tomorrow I will get the whole story assuming they have it fixed and I'll update the forum.

Wxchaser 12-29-2011 07:34 PM

Re: In the shop
 
Good luck with those repairs, thanks for giving us a clue to possible solutions.

jp467 12-29-2011 08:45 PM

Re: In the shop
 
Is this the first problem you have had with qudra lift?

Red G8R 12-29-2011 10:10 PM

Re: In the shop
 
No. It has been messaging me "system cooling down" on and off only during cold weather.

Red G8R 12-30-2011 08:06 PM

Re: In the shop
 
Well, the dealer still has the Jeep. They have no idea why the air suspension failed and they will have to keep it for the weekend. Not sure if the climate control failure is related. I forgot to mention that my tpms was also alarming, left rear was borderline low but it was -13 C. With all that, the Jeep was drivable. Could a CPU be responsible for all three???

I was offered a rental.

jp467 12-30-2011 08:12 PM

Re: In the shop
 
I would think the air suspension is probably its own issue. You said you had been getting the system cooiling down message. This could indicate the system was low and nitrogen and the compressor was running too much and overheating. I would guess its either low on nitrogen or the compressor is bad or possibly both now. Did they say if the nitrogen level was normal?

Red G8R 12-31-2011 08:47 AM

Re: In the shop
 
Went back this am and spoke with the service manager. He explained that there is a small leak in the system but it takes multiple steps to pin point it waiting 3hrs between steps. The compressor has been working overtime (system cooling down warning) and so the compressor will have to be changed but the leak has to be found first. He was definitely more reassuring than the service adviser who kept saying "we have no clue".

It's a holiday here on Monday so Tuesday is the only day before I fly out for holidays and I need the jeep to get to the airport. He kindly offered me a rental minivan (5 of us) to go to the airport and back if it's not ready by Tuesday evening.

jp467 01-10-2012 03:13 PM

Re: In the shop
 
Any update on this?

fireron 01-10-2012 05:33 PM

Re: In the shop
 
I have had mulitple problems with my QL. They have refilled the system twice, replaced the compressor, and they are currently replacing all of the lines from back to the front. Today they told me after all of that, the module for the QL is also out so currently waiting for that to come in. So, in the 10 months I have had my Summit, I have never been able to use the Rock setting for more than 5 minutes at a time so there has been virtually no off-road time for mine. Add that to the 730N fiasco and a bad rear driver's side half shaft, my experience with the JGC has been anything but Grand. If it is not fixed this time, I'm afraid it is time for a little lemon squeezing to commence. It is really a shame because we love the Jeep and dealership, who has been great.

jp467 01-10-2012 10:52 PM

Re: In the shop
 
Quote:

Originally Posted by fireron (Post 549907)
I have had mulitple problems with my QL. They have refilled the system twice, replaced the compressor, and they are currently replacing all of the lines from back to the front. Today they told me after all of that, the module for the QL is also out so currently waiting for that to come in. So, in the 10 months I have had my Summit, I have never been able to use the Rock setting for more than 5 minutes at a time so there has been virtually no off-road time for mine. Add that to the 730N fiasco and a bad rear driver's side half shaft, my experience with the JGC has been anything but Grand. If it is not fixed this time, I'm afraid it is time for a little lemon squeezing to commence. It is really a shame because we love the Jeep and dealership, who has been great.


How does yours ride in that hot weather. Just wondering because my Overland always seems to ride sitffer in the hot weather. It could be just in my head but there does seem to be a difference.

fireron 01-11-2012 06:59 AM

Re: In the shop
 
I don't recall there being any difference really. Of course, mine has been without proper nitrogen charge for most of it's life and the fact that when it does get low it brings in outside air to complement the system, that it may never have been "normal" in ride quality. I'm hoping to find out though, however hope is fading at this point!

Red G8R 01-11-2012 08:05 AM

Re: In the shop
 
Quote:

Originally Posted by jp467 (Post 549805)
Any update on this?

They had it in the shop for 4 days, no leaks found, they spoke with engineering and they will change the compressor which is on order. I drove it to the airport a week ago and it's currently sitting there till I get back in two more days.


All times are GMT -5. The time now is 05:30 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community