Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   4.0 cooling issue (http://www.jeepgarage.org/f196/4-0-cooling-issue-33277.html)

jeffs2014 12-30-2011 03:04 PM

4.0 cooling issue
 
2004 wj 4.0. what is the normal running temp that i should be at? if i auto start and let the jeep warm up for 15 mins its at about 160 to 180 degree and heat works great. when i drive the engine temp slowy gets cooler and runs at like 120 which sends on my check engine light. WTF is the deal. its got New coolant, new electric fan. new rad and new therostat. Heat works as long engine stays warm which it i cant seem to get to happen.

imaguy3 12-30-2011 03:10 PM

Re: 4.0 cooling issue
 
sounds like the thermostat is stuck open. Did you change the thermostat or just going by what someone else told you? If you change it yourself it's always a good idea to test it before installing it so you don't have to do it a 2nd time. I learned that the hard way (installed one that refused to open at temp.) :-\ Easy to test though, just get some water to hotter than the temp of the thermostat and see if it opens...

JeepMe 12-30-2011 10:26 PM

Re: 4.0 cooling issue
 
If you drive the Jeep for 30 to 60 minutes does it finally get up to normal operating temperature (roughly 200 degrees)?

imaguy3 12-31-2011 09:37 AM

Re: 4.0 cooling issue
 
Quote:

Originally Posted by JeepMe (Post 543039)
If you drive the Jeep for 30 to 60 minutes does it finally get up to normal operating temperature (roughly 200 degrees)?

He stated when he's driving it it cools down from 180 to 120. If the thermostat was working properly it would close as soon as the temp. dropped and would never get that cold once warmed up (until it was shut off). This leads me to think it's sticking open and not closing...

It should never take 30 min. for the car to get warm...

Gus9890 12-31-2011 09:54 AM

Re: 4.0 cooling issue
 
Sounds like it may be the thermostat

JeepMe 12-31-2011 10:02 AM

Re: 4.0 cooling issue
 
Quote:

Originally Posted by imaguy3 (Post 543244)
He stated when he's driving it it cools down from 180 to 120. If the thermostat was working properly it would close as soon as the temp. dropped and would never get that cold once warmed up (until it was shut off). This leads me to think it's sticking open and not closing...

It should never take 30 min. for the car to get warm...

Congrats on reading 101, I graduated that also. :thumbsup:
But I don't see anywhere where he answered my question.

I know, if it does get warm in 30 minutes I would also say that the thermostat is stuck open. If it does NOT get warm in 30 minutes then he has a bigger issue.

I've had thermostats stuck open in my vehicles before and they will eventually get warm. All I was asking was to see if that's the case.

jeffs2014 12-31-2011 10:28 AM

Re: 4.0 cooling issue
 
sorry about the delay. it only gets to 200 when its sitting for awhile. as soon as i drive temp drops. i hate doing the termostat. i have to double up the gasket or the housing wil slowly drip so it a pain for me to do. i was hoping i didnt have to chnage that again. i went to oreillys and the guy told me to never but that fail safe theromstat again which was 16 bucks so i went this morning n bought a cheapy for 3 bucks. which me luck and thanks alot for the help.


All times are GMT -5. The time now is 10:32 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community