Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Smartbeam does not work (http://www.jeepgarage.org/f107/smartbeam-does-not-work-33348.html)

JMBRITANIK 01-01-2012 02:29 PM

Smartbeam does not work
 
2011 Overland - Left headlight keeps burning out - now smartbeam does not work nor will the high beams come on unless you keep holding the switch on. There is also a flashing light on my rearview mirror now?? Dealer has looked at it at least 6 times. :confused:

77Cherokee 01-01-2012 06:17 PM

Re: Smartbeam does not work
 
If it has been in 6 times for the same problem it sounds like a possible lemon law return, or you should try another dealer.

armoredsaint 01-02-2012 11:46 AM

Re: Smartbeam does not work
 
Need more info brosef.

smahoney 01-04-2012 03:39 PM

Re: Smartbeam does not work
 
I had the same rearview mirror flashing issue.

Try this thread: http://jeepgarage.org/showthread.php?t=26541

jeep2011 01-07-2012 11:12 PM

Re: Smartbeam does not work
 
Same here. Sometimes I can get smart beam to activate while other times it is only manual operation. Even pulling over, checking and unchecking smart beam in the EVIC doesn't help. Brought to the dealer twice they realigned the headlights, but then again I don't really think they know what I am trying to show them.


All times are GMT -5. The time now is 04:17 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community