Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Battery???? (http://www.jeepgarage.org/f107/battery-33553.html)

DavidB 01-05-2012 11:36 AM

Battery????
 
Has anyone had a battery go out on the WK2 yet? Sent the GC down to the dealer once again on the back of a flatbed once again. We have been having wierd issues as of late. for example, the security system locked us out (on a rainy day of all things) and the wipers started to move slowly, all we had to do it hit the red button twice and it unlocked though. The seats will not keep memory. Just little things like that. Well, yesterday it finally went to pot. The GC would not start, sounded like a dead battery but everything would turn on at first. Then the window would then wouldnt work. then out of the blue the wipers started working very slowly (they were turned off too). Call the dealer this morning and they are trying to tell me that it sounds like a battery because its dead. I insisted that it was not and the only reason why the battery was dead is because the wipers were on and could not be turned off and they were on the whole trip down to the dealership (45 minutes). I seen a post on here about demon possesion and Im kinda thinking that is what it is. Any ideas out there or should I be looking for a sacrificial ford explorer.

pcastro1111 01-05-2012 03:43 PM

Re: Battery????
 
Hi,

Two weeks ago I had a dead battery issue with my late 2011 Overland with 3k miles on it. After leaving my GC parked for 3 days (I'm sure I didn't leave anything on when I parked the car), it would not start. No starter cranking engine, and every electronic running very dim or slow, after a couple of tries the wipers started by themselves very slowly and then I couldn't even lock or unlock the doors with the door lock buttons. Finally my neighbor helped me jump starting and everything has been fine since then (fully charged my battery that night to be sure).

Something strange happened those 3 days that drained my battery, I have read somewhere that there were issues with the power lift gate activating itself searching for a keyfob nearby and draining the battery... maybe this was my case... no idea.

DavidB 01-05-2012 03:55 PM

Re: Battery????
 
Quote:

Originally Posted by pcastro1111 (Post 546267)
Hi,

Two weeks ago I had a dead battery issue with my late 2011 Overland with 3k miles on it. After leaving my GC parked for 3 days (I'm sure I didn't leave anything on when I parked the car), it would not start. No starter cranking engine, and every electronic running very dim or slow, after a couple of tries the wipers started by themselves very slowly and then I couldn't even lock or unlock the doors with the door lock buttons. Finally my neighbor helped me jump starting and everything has been fine since then (fully charged my battery that night to be sure).

Something strange happened those 3 days that drained my battery, I have read somewhere that there were issues with the power lift gate activating itself searching for a keyfob nearby and draining the battery... maybe this was my case... no idea.

Your discription sounds very familiar to what happen here. The only difference was that about a month ago my wife went downtown with it and when she came out of the store (15 minutes max) it acted the same way. she hit the red button on the fob twice and it seemed to start working for whatever reason. Thanks for the input. Ive just got this feeling that its not the battery and perhaps something like the hatch issue is what is happening. My 2000 GMC Sierra had a battery go bad out of the blue last August. I replaced it and then two weeks later the samething. I later discovered the passanger side seat adjuster had stuck in the forward position so it was draining the battery.

DavidB 01-05-2012 05:58 PM

Re: Battery????
 
update: they called and said the battery is shot so they need to order one but it might not be in till monday grrrrr. I was told they cant even run any test till they have a good battery.

DavidB 01-05-2012 07:28 PM

Re: Battery????
 
I thought this was real interesting. I was just never aware it
http://www.youtube.com/watch?v=e5oCOyUvOkc

jerryw1000 01-05-2012 09:04 PM

Re: Battery????
 
Quote:

Originally Posted by DavidB (Post 546426)
I thought this was real interesting. I was just never aware it
http://www.youtube.com/watch?v=e5oCOyUvOkc


How dumb am I? I never noticed. I guess it's true because I have never seen a light or anything . Don't they usually illuminate when you first turn the ignition to the On position? I can't believe they didn't even put an alternator idiot light.

DavidB 01-05-2012 09:15 PM

Re: Battery????
 
Quote:

Originally Posted by jerryw1000 (Post 546513)
How dumb am I? I never noticed. I guess it's true because I have never seen a light or anything . Don't they usually illuminate when you first turn the ignition to the On position? I can't believe they didn't even put an alternator idiot light.

Im glad i wasnt the only one that didnt know that. Of all of the items in the info center I have to wonder why not the volts or amps

Sharptail 01-06-2012 03:17 AM

Re: Battery????
 
I am sure this information is wrong. While I can't check my Jeep right now, both the User's Guide and the iPhone app show a charging system warning light (depiction of a battery in red). Perhaps someone near their vehicle can take a quick peek to be sure.


Sharptail

77Cherokee 01-06-2012 12:05 PM

Re: Battery????
 
This from the manual:



"Charging System Light


This light shows the status of the electrical charging
system. If the light stays on or comes on while
driving, turn off some of the vehicle’s non-essential
electrical devices or increase engine speed (if at idle). If
the charging system light remains on, it means that the
vehicle is experiencing a problem with the charging
system. Obtain SERVICE IMMEDIATELY. See an authorized

dealer."

This does not say the light comes on as a test when you first start the engine, like the other warning lights do. It must be programmed to come on only if there is a problem. I can't explain the video posted above as to why the light never came on.

DavidB 01-06-2012 12:10 PM

Re: Battery????
 
Quote:

Originally Posted by 77Cherokee (Post 546852)
This from the manual:



"Charging System Light

This light shows the status of the electrical charging


system. If the light stays on or comes on while
driving, turn off some of the vehicle’s non-essential
electrical devices or increase engine speed (if at idle). If
the charging system light remains on, it means that the
vehicle is experiencing a problem with the charging
system. Obtain SERVICE IMMEDIATELY. See an authorized



dealer."


This does not say the light comes on as a test when you first start the engine, like the other warning lights do. It must be programmed to come on only if there is a problem. I can't explain the video posted above as to why the light never came on.

In the light of that I would assume that as long as the Battery is charged it will not come on. So if your alternator goes out, your warning light would stay off until your far enough down the road and about 5 miles from the next service station to come on. Seriously that would explain the reason that the light didnt come on in the video

77Cherokee 01-06-2012 06:04 PM

Re: Battery????
 
That is certainly possible, although I seriously doubt that they meant to design it that way. :rolleyes:

Cherodude 01-06-2012 07:13 PM

Re: Battery????
 
The EVIC display can show more icons than can be displayed all at one time. In other words, the battery charge icon shares the same space as the Service 4WD icon, etc. When you start the Jeep, a bunch of the icons light up to show the system is working, but it is a matter of chance whether the Battery Charge one will be lit up, since another icon may be using its display space.

Try it. Start and watch the EVIC. The coloured icons displayed are slightly different each time (at least it is on mine). I get the battery charge one about every fourth start.


All times are GMT -5. The time now is 11:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community