Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Accelerate issue (http://www.jeepgarage.org/f181/accelerate-issue-34291.html)

303WK 01-18-2012 04:18 PM

Accelerate issue
 
Ok guys help me out. When I am driving to work I get to this light and have to turn right. as I turn I hit the gas to get over this small
Hill, well once I hit the gas (accelerate) it seems like the transmission down shifts to first gear and my rpm goes to like 5 or six then I'll let off a lil bit and it will catch and be all good. This only happens when i hit the gas real hard... I don't know if any one has has this same problem. Is it the egr or my tranny?? I have a 05 laredo with the v8

Please any input would be great!!

Thanks guys...

4.whoa 01-19-2012 03:16 PM

Re: Accelerate issue
 
Quote:

Originally Posted by 303WK (Post 555414)
once I hit the gas (accelerate) it seems like the transmission down shifts to first gear and my rpm goes to like 5 or six then I'll let off a lil bit and it will catch and be all good. This only happens when i hit the gas real hard..

When you "floor it ",it will do that.It knows you want to go,so its giving its all. Now if it does it at part throttle,you could have a problem.
If you dont let up,it does shift, right?

2005JGC 01-19-2012 04:21 PM

Re: Accelerate issue
 
Quote:

Originally Posted by 4.whoa (Post 556083)
When you "floor it ",it will do that.It knows you want to go,so its giving its all. Now if it does it at part throttle,you could have a problem.
If you dont let up,it does shift, right?

This, sounds like normal operation by your description "hit the gas hard".

303WK 01-19-2012 05:21 PM

Quote:

Originally Posted by 4.whoa (Post 556083)
When you "floor it ",it will do that.It knows you want to go,so its giving its all. Now if it does it at part throttle,you could have a problem.
If you dont let up,it does shift, right?

Im not flooring it, it's about half throttle just to get it to down shift and get goin. When ever it happens I have to let up a bit, I think if I don't let up I will red line. But once I let up a bit the rpm will go Down a lil bit then go into 3.... I'm goin to do a tranny fluid change I'm due I think...

303WK 01-19-2012 05:29 PM

It's like when it down shifts, it misses 2 and goes to first. That's what it feels like..

4.whoa 01-20-2012 03:05 AM

Re: Accelerate issue
 
My hemi used to do that, it would pause then drop into 1 st. Now i have a predator with a FlyinRyan trans tune. It drops 1 gear, unless you really hit it( the way it should) . Have you held it down till it shifts? It should hit 2 nd pretty good right at " redline" when your on it. If/when you let off it will pause a sec ( kinda like its sayn " wha?") To be sure you want it. Thats how mine was stock anyway.

kennzz05 01-20-2012 06:08 AM

Re: Accelerate issue
 
sounds normal. if you have autostick you could force it into 1st when you are at the slowest part of the turn which would stop the whiplash effect than just up shift to D and let it do its own shifting the rest of the way


All times are GMT -5. The time now is 11:27 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community