Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Electrical issues (http://www.jeepgarage.org/f181/electrical-issues-34558.html)

tri0829 01-23-2012 12:04 PM

Electrical issues
 
Okay so I'm not sure if there is a thread somewhere that could help me I searched but couldn't come up with one if you know of one please give me the link....that being said here's my issue:

Recently my wk has been behaving very strange it see,ms like the electronics are going crazy, one thing after another. I'm not sure if theyre all related but I know that some have to be.

First thing to happen my passenger window will not stay up unless I hold the up switch for like a minute it either goes up and comes down half way where it stops or it goes up and then down like an inch and stops.

Next to happen one of my headlights kept not turning on I figuered out that the relay I had for the hids wasn't making intact somewhere, jiggling it fixed it.

I got new speakers for Christmas and installed them all to go with my newer head unit, all went well.

After a month my speedo cluster started spazzing out, this is what concerns me most. I have no clue what's wrong with it. Twice this happened, the speed pointer and rpm pointer jumped as I was driving and then returned to normal a few lights flashed on the cluster also and my headlights flickered. The car behaved normally during this time minus that. It hasnt done it sense but now the driver side blinker occasionally spazzes out and blinks super fast, I thought maybe the bulb was out but it's not. (i have led tails idk if that matters but theyve been working fine since i installed them last year) I also have LEDs hooked up in the fog lights and they recently wouldn't turn on I haven't checked the wiring yet but I'm hoping it's not related.

Sorry for the long winded post can anyone help me out? I'm trying to avoid the dealer if I can.... Thanks in advance

tri0829 01-23-2012 12:11 PM

Re: Electrical issues
 
Also forgot to mention that the one oxygen sensor went and it was after that these issues started occurring, the dealer fixed the o2 sensor


All times are GMT -5. The time now is 03:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community