Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   predator tune ran like crap (http://www.jeepgarage.org/f5/predator-tune-ran-like-crap-37012.html)

IDOCTCC 02-09-2012 07:36 PM

predator tune ran like crap
 
I've got an 05 GC 5.7, i just bought a Predator and installed the 87oct tune. Took it for a drive and it ran like crap, it spit and sputtered and wanted to die. Nothing about it was right about it. Only mod is an airaid intake. Confused and disappointed? Any help? BTW i re-installed factory tune and had to pull neg battery cable for it to reset. For a minute i thought i had really jacked up the Jeep.

Chaoul1 02-09-2012 07:46 PM

Re: predator tune ran like crap
 
Did you play with any of the settings?

Make SURE you have the correct Octane in your Fuel Tank. If not then maybe that's why it ran like crap.

IDOCTCC 02-09-2012 07:56 PM

Re: predator tune ran like crap
 
Nope 87oct in the tank. Even at idle it was wanting to die.

99formulam6 02-09-2012 08:01 PM

Re: predator tune ran like crap
 
That is weird. All I can suggest is try again, or try a different tune (MPG maybe?). I have run that tune and the others with no issues.

Did you have any problems while doing the install?

IDOCTCC 02-09-2012 08:06 PM

Re: predator tune ran like crap
 
Install went fine, kinda worried to do another one. Dont want to have to explain to the wife if the tune sticks and it sucks.

dssilvestri 02-09-2012 08:43 PM

Re: predator tune ran like crap
 
check the support forums at the DS website, try disconnecting the neg terminal on the battery, re connect it then install again.

Crestwood1001 02-09-2012 11:41 PM

Re: predator tune ran like crap
 
NEVER heard of this happening by fault of the tuner. Check out their forum

IDOCTCC 02-09-2012 11:54 PM

Re: predator tune ran like crap
 
If when i reinstall the tune next time i will unplug neg cable after the tune and see if reseting everything the PCM takes the tune. It's hard to do something wrong, its plug and play i realize this thats why i was wondering if it had maybe happened before.

4.whoa 02-10-2012 04:07 AM

Re: predator tune ran like crap
 
The same thing happened to me the 1 st time,was like it was only running on a couple cylinders . Just reload the tune and pull the neg cable for a few min.

4.whoa 02-10-2012 05:36 AM

Re: predator tune ran like crap
 
FYI you dont need to return it to stock in order to reload a tune.

IDOCTCC 02-10-2012 10:07 AM

Re: predator tune ran like crap
 
Thats exactly what it felt like, only running on a couple cylinders. I will try it again maybe bump up to 89oct after i fill up. I only untuned it bc of the way it was running and didn't want to explain to the wife.

JeepCoop 02-10-2012 10:38 AM

Re: predator tune ran like crap
 
Yup reinstall it and then reset the PCM. It needs to adjust to the tune and your driving. It happens


All times are GMT -5. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community