Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Radio Preset Button Issues (http://www.jeepgarage.org/f107/radio-preset-button-issues-37291.html)

prelude532 02-14-2012 01:52 PM

Radio Preset Button Issues
 
Curious if anyone else is having issues with the Radio preset button on the back of the steering wheel. In the Laredo X, since pretty much day 1, its not consistent. I've had it in twice and both times the dealer says that can't replicate the problem. I'm about to take it to another deal in hopes that I can also get my LEDs in the door handles/door pockets turned on since the same dealer says that my Jeep doesn't come with them. My wife has a WK2 Limited and my father has a WK2 Overland and both of their preset buttons feel more "clicky" for lack of a better term and even when I don't hit them EXACTLY on, they still seem to do the job. If i'm even off the slightest when I try to press mine, it just channels up or down. FWIW, both of those other vehicles also had the LEDs lit up correctly coming off the lot.

Curious if anyone else was/is experiencing this.

Jeeters 02-14-2012 04:12 PM

Re: Radio Preset Button Issues
 
No issues with mine. I use them *a lot* when listening to Sirius - I'm constantly 'channel surfing' with them. Laredo X with 430N.

RageOfFury 02-14-2012 07:37 PM

Re: Radio Preset Button Issues
 
I experience the exact same issue!!! It's such a pain in the you know what.

I'm going to have the dealer replace the switch whenever I get around to it.

PECo 02-14-2012 08:39 PM

Re: Radio Preset Button Issues
 
No problems with mine.

12167jeep 02-14-2012 09:12 PM

Re: Radio Preset Button Issues
 
I have the same issues with mine, there is a TSB out for the buttons. As for the leds, i got the same story from two dealers and even their "field service tech" for the area.

RageOfFury 02-14-2012 09:15 PM

Re: Radio Preset Button Issues
 
Quote:

Originally Posted by 12167jeep (Post 574120)
I have the same issues with mine, there is a TSB out for the buttons. As for the leds, i got the same story from two dealers and even their "field service tech" for the area.

There is?:confused:

12167jeep 02-14-2012 09:24 PM

Re: Radio Preset Button Issues
 
Quote:

Originally Posted by RageOfFury (Post 574122)
There is?:confused:

Ok so i was mistaken, i knew i read it on the TSB page though. It at the bottom in purple for builds before 7/10. Says to replace the switch

http://www.wk2jeeps.com/wk2_tsb.htm

Jeeters 02-15-2012 07:09 AM

Re: Radio Preset Button Issues
 
Quote:

Originally Posted by 12167jeep (Post 574129)
Ok so i was mistaken, i knew i read it on the TSB page though. It at the bottom in purple for builds before 7/10. Says to replace the switch

http://www.wk2jeeps.com/wk2_tsb.htm

I just read that and it made me chuckle... So if your buttons are sticking, and your build date is before 7/2010, they say replace the switches. So I guess if your buttons are sticking but your build date is after 7/2010 you're SOL?

prelude532 02-15-2012 09:53 PM

Re: Radio Preset Button Issues
 
Just wanted to update. After going to a new dealership, they diagnosed it as a bad switch and replaced the buttons in the steering wheel. Works like a champ now.

RageOfFury 02-16-2012 06:45 PM

Re: Radio Preset Button Issues
 
Quote:

Originally Posted by prelude532 (Post 574765)
Just wanted to update. After going to a new dealership, they diagnosed it as a bad switch and replaced the buttons in the steering wheel. Works like a champ now.

Sweet! I gotta find time to do that!


All times are GMT -5. The time now is 06:13 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community