Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Tow Hitch Wiring Problem (http://www.jeepgarage.org/f107/tow-hitch-wiring-problem-37572.html)

Lifeon2whls 02-19-2012 12:09 PM

Tow Hitch Wiring Problem
 
So I was supposed to be on the race track today but instead I am here meeting you fine people...hello from Los Angeles!

I went into U-Haul last night to pick up my motorcycle trailer and I have the OEM trailer tow group that was installed prior to buying the GC. When they hooked it up and asked me to try my turn signals, etc we found that they didn't work. Only the right side of the trailer's lights would flash and on the Jeep, when I put the right turn signal on, not only would the Jeep's right signal blink, but the left one would as well...but only faintly. So fo course...no trailer for me.

The first question I got was whether or not this was factory. The only time they've ever seen this was when the person did the install themselves. Their thought is that the converter is bad.

I'm going to take this in to have the dealer fix this but anyone else have any similar issues. Also...is this a dealer installed option or was this done at the factory. I've had some serious issues with the dealer I got my Jeep at and am thinking about going elsewhere to have this done.

RageOfFury 02-19-2012 04:47 PM

Re: Tow Hitch Wiring Problem
 
Sounds like a bad hook up of the harness when the hitch was installed. The dealer also has to enable the harness via their scan tool.

Back to the dealer!:(

Welcome by the way:thumbsup:

Lifeon2whls 03-21-2012 06:43 PM

Re: Tow Hitch Wiring Problem
 
So I went back to the dealer and they are telling me that they cannot find any problems. They want me to come in with a trailer but U-Haul wont let me leave with a trailer if the turn signals dont work so that's not an option.

Anyone have any ideas?

nek121328 03-21-2012 07:24 PM

Re: Tow Hitch Wiring Problem
 
Plug in one of the tester light units available at most auto parts stores. They're the flat four wire units. Cheap and easy.

Justal13 03-21-2012 07:30 PM

Re: Tow Hitch Wiring Problem
 
Was the hitch installed at the factory or by the dealer? Did U-Haul use the 7-pin or 4-pin plug (I would think 4-pin). You can purchase a tester for either from Amazon to test it yourself:

7-pin:
http://www.amazon.com/Curt-Manufactu...2375617&sr=8-6

4-pin:
http://www.amazon.com/Curt-58260-4-F...2376119&sr=1-4

Based on a lot of experience with U-Haul and the neanderthals they seem to attract and hire, I would believe the problem was with their trailer - not your GC. I have had this happen several times at U-Haul myself, and ended up showing the U-Haul mechanic the problems with their equipment and how to fix it.

U-Haul equipment is typically poorly maintained at best - tires, wiring, bad bulbs, doors, ramps - many issues. I check their crap over front to back and document everything wrong, or they will try to charge you for it upon the return. Unfortunately, they are often the only game in town - particularly if you want to pick up and drop off many miles away.

Best luck.

Ratchet 03-22-2012 06:32 AM

Re: Tow Hitch Wiring Problem
 
Might not hurt to look into this if you have a 2011 model year.
http://www.wk2jeeps.com/tsb/tsb_wk2_0801810.pdf

Lifeon2whls 03-22-2012 12:55 PM

Re: Tow Hitch Wiring Problem
 

Ratchet...you sir may have the answer as there was a TON of silicone in there! I was shocked actually when I opened the cover for the first time but I have a 2012...still can't hurt to clean it all off.


That said I got my Jeep back from the dealer this morning. They checked everything and there were no issues. I even had them make sure that the option code had been activated and they confirmed it had.

When I went into U-Haul the first time, we tried with two different trailers and had the same problem. I rent trailers from the same location on a regular basis and never had any issues with my Tacoma, but two trailers having the same problem points to an issue with my vehicle. We also tried using the 7-pin and 4-pin connections as I have an adapter for the 7-pin and we had the same issues with both.

So I will try cleaning off any silicone and go back over to U-Haul and see if there is any resolution. I would prefer not to buy a test tool as I really have no other use for it and would prefer not to spend the money, but if I have to I will.

NickHowes 03-23-2012 06:55 AM

Re: Tow Hitch Wiring Problem
 
FWIW, I'm also having problems with the trailer hookup (7 pin). It worked fine for a few months, but not any more. I usually tow with another vehicle and the trailers work fine with it. The fuses are all good and I also have a tester: it shows that the trailer connector is completely dead on the JGC. I'll have the dealer look at it next time it's in for service - probably not for a month or two.

duce95 03-25-2012 01:40 PM

Had the same issue. Dealer has to activate it on your tipm. They have to switch the tow hitch in by changing it to a dealer installed option.

Pedrods 06-26-2012 06:48 PM

Re: Tow Hitch Wiring Problem
 
I had a hitch installed by U-Haul and they told me there was a problem with the electric and I should take it to the dealersince it was a brand new vehicle, so I did, it turned out they had to activate the electric conection by conecting the vehicle to the computer. They asured me that would take care of it, they charge $110 + tax to do it. I am yet to discover if that took care of it. I am going for a week vacation to the Hatfields & McCoys land and I am towing my Harley. I will let you know if that fixed the problem in a couple of weeks.


All times are GMT -5. The time now is 10:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community