Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   FYI...CEL on solid @ approx 15k...appt set for 130pm today... (http://www.jeepgarage.org/f107/fyi-cel-on-solid-approx-15k-appt-set-for-130pm-today-38970.html)

MichiganFan 03-15-2012 10:54 AM

FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
Yup...hit the road today, to take wife to doctor (she drove), and CEL came on solid about 10mins into trip (trip was 1.5hrs one way)...called dealer Svc Dept & they advised that as long as it wasn't flashing we were OK, and they set up appt for 130pm CDT today...but if it started flashing, kill the engine & call a tow truck.

So...will report back with update later this evening, after diagnostic is done.

Interesting, haven't had any issues with Jeep, and the CEL doesn't seem to be affecting driveability any...so curious to know what turned it on.

Updates:

Correction - appt moved to 230pm, due to heavy traffic...at dealer, they advised that they would get it in & Diag it within the hour.

Ok...so, they got it in for Diag...all done by 3pm...5mins w/ Svc Mgr...10mins at Cashier (waiting for receipt)...out the door by 315pm, new record!!!...lol.

Apparently it spit out an EVAP code, but only once...so it appears that the Gas Cap was at fault...I figured 1-click after a fill-up was sufficient, but I guess I need to get about 3-4 clicks on the Cap, to make sure it seals correctly...lol...oh well.

Just glad that there wasn't anything really wrong with it...it spit a single one-time code, they rest it, drove it, no more codes...so good to go!! :)

UPDATE - 3/19...CEL came back on again yesterday, so JGC is back at dealer today (as of 1130am) for further diagnosis...currently chilling at dealer, awaiting word on it.

Ok...so Svc Mgr advised that there was some false signaling/communication with PCM, so they are going to replace PCM around Wed to Fri this week, after the parts arrive.

armoredsaint 03-15-2012 03:22 PM

Re: FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
Cel?

bmrisko 03-15-2012 03:29 PM

Re: FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
Quote:

Originally Posted by armoredsaint (Post 594424)
Cel?

Check Engine Light

padgett 03-15-2012 04:10 PM

Re: FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
Check Engine Light (CEL), Service Engine Soon (SES), Malfunction/Mutifunction Indicator Light (MIL) all same-same.

jerryw1000 03-15-2012 09:43 PM

Re: FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
My service advisor told me today that some of the CELs they were seeing on GCs were from people who tend to keep bumping the gas nozzle after it shuts off until the gas is all the way up in the filler neck and it gets into the vapor tube. Apparently that's not good for the emission control system and throws a CEL. I told him they did not have to worry about me doing that. At $4 a gallon I'm happy to stop when the pump kicks off.

BimmerAgent 03-16-2012 11:25 PM

Re: FYI...CEL on solid @ approx 15k...appt set for 130pm today...
 
It's a common issue on a cel....first thing to check is your filler cap, and don't overfill your tank. Bruce


All times are GMT -5. The time now is 04:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community