Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Air Conditioning Problem (http://www.jeepgarage.org/f107/air-conditioning-problem-39320.html)

CollegeBoy 03-20-2012 03:32 PM

Air Conditioning Problem
 
I have a 2012 Overland and today was the first day that it was hot enough to turn on the A/C. Big disappointment when it didn't work. Had it on auto and set at low as well as on manual set all the way down with A/C switch on. No cold air whatsoever. From time to time in the last couple months I noticed that when I had auto set to 19 C (66 F) it would sometimes feel like quite cold air almost like the A/C was on. Outside temps were in the low 30's F.

Has anyone else had a similar problem? The vehicle is less than 6 months old.

Chaoul1 03-20-2012 05:27 PM

Re: Air Conditioning Problem
 
Can you hear the A/C compressor engaging?

Darby Crash 03-20-2012 05:32 PM

Re: Air Conditioning Problem
 
I had an A/C problem too until I had my Jeep flashed with new software or whatever....works really good now.

CollegeBoy 03-20-2012 07:13 PM

Re: Air Conditioning Problem
 
Quote:

Originally Posted by Chaoul1 (Post 597298)
Can you hear the A/C compressor engaging?

No. A/C button light comes on but no change in engine sound at idle. Can't hear any change in sound. Continues to blow warm, I assume, engine compartment, air.

hammer1234 03-21-2012 05:53 AM

Re: Air Conditioning Problem
 
I've had two leaks fixed on my 2011 GC in the first year, one involving the liquid line (TSB 24-006-10) and the other involving the condenser. In the first case the AC system made a hissing noise but in the second case all that happened was a loss of AC and no AC engagement. I suspect that the system does not engage when the refrigerant is low but there is no clear error shown to the driver.

Time to get the Jeep to the dealer...

CollegeBoy 03-21-2012 06:17 PM

Re: Air Conditioning Problem
 
Thanks. Took it in to the dealer today. They say there was no freon (or whatever the refrigerant is). Apparently zero pressure in system. They refilled and added dye. Guess I now wait and see. I'm not sure why they don't book you for a follow-up to inspect for leaks. Get the sense that I have to wait for the next fail. I did mention possible TSB, but no they gave no indication that this was a known problem.

hammer1234 03-21-2012 08:13 PM

Re: Air Conditioning Problem
 
Quote:

Originally Posted by CollegeBoy (Post 597973)
Thanks. Took it in to the dealer today. They say there was no freon (or whatever the refrigerant is). Apparently zero pressure in system. They refilled and added dye. Guess I now wait and see. I'm not sure why they don't book you for a follow-up to inspect for leaks. Get the sense that I have to wait for the next fail. I did mention possible TSB, but no they gave no indication that this was a known problem.

When I had the dye done for the first repair I took it back in a few weeks. Second repair took less for them to isolate.

My guess is that unless they see a bunch of vehicles with the same problem they won't say much.

Good luck and hope it isn't the evaporator...IIRC I was told that replacing that involves taking the dashboard out.


All times are GMT -5. The time now is 03:30 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community