Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Turning issue with the WK (http://www.jeepgarage.org/f181/turning-issue-with-the-wk-39806.html)

streetmike 03-26-2012 05:13 PM

Turning issue with the WK
 
So my 2005 WK seems to be riding rougher and rougher these days. I know the wrangler silent armors are down to 6k or so left. I also figured I am do for some new shocks soon since I am at 75k (dealer supposedly replaced them under extended warranty). Anyways last friday I went to make a left turn from a stop. Traffic was coming so it was going to be a quicker turn. I start to turn the wheel before I let of the brake and it feels like the wheel locked on me. I maybe turned it a few inches. I release my grip and try again and it turns fine. Then today I was parking at work and I turned the wheel to full lock to turn into a spot and half way through turning it kinda makes a clunk and a shake like a wheel jumped. I stopped and thought I might have tapped one of the other parked cars, but realized I wasn't close enough. Then on the way home I am driving through my sub and get to my street. I slow down to 5 to 10ish to turn and the Jeep feels like it bogged down during the turn and noticed the TCS light flashing. Hmmm... I am starting to hate this ride! I have think it was probably built the day after St. Patties say or something because it seems like there is one problem after another.


So before I have to take it to a shop, what do you guys think? If you need more info let me know and I will try and provide it.

Its a...
2005 WK
4.7L QT2
over 75k on it

Thanks for the help
Mike

SvenskaJeepGuy 03-26-2012 05:28 PM

Re: Turning issue with the WK
 
Have you checked the ps fluid? Mine was low once and i had a hard time turning, not as bad as you described but i could feel a difference.

streetmike 03-26-2012 05:32 PM

Re: Turning issue with the WK
 
Quote:

Originally Posted by SvenskaJeepGuy (Post 601040)
Have you checked the ps fluid? Mine was low once and i had a hard time turning, not as bad as you described but i could feel a difference.

Yea I will take a look. I take it to Valvoline for the oil change and they are usually pretty good about checking all the fluids.

edit:

Just checked and its full

dr.lee.baugh 03-26-2012 07:14 PM

Re: Turning issue with the WK
 
Could be an issue with a wheel speed sensor (especially if the traction control light is coming on). These are a relatively easy / cheap solution.

Could also be a fluid quality issue in the differentials and/or transfer case. Have these been checked? When was the last time they were replaced?

Those would be where I would start.

streetmike 03-26-2012 07:34 PM

Re: Turning issue with the WK
 
Quote:

Originally Posted by dr.lee.baugh (Post 601098)
Could be an issue with a wheel speed sensor (especially if the traction control light is coming on). These are a relatively easy / cheap solution.

Could also be a fluid quality issue in the differentials and/or transfer case. Have these been checked? When was the last time they were replaced?

Those would be where I would start.


T-case and axle fluid was replaced maybe 5K miles or so at Valvoline.

If its a speed sensor, is it easy to replace for someone without much mechanical knowledge? lol


All times are GMT -5. The time now is 12:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community