Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Is this normal? (http://www.jeepgarage.org/f181/is-this-normal-39895.html)

JDubz 03-27-2012 10:45 PM

Is this normal?
 
I know this is probably a dumb question. I have noticed that if I try to rev the engine when it is in park/neutral, it will rev but then I have to wait for the RPMs to go back down before I can rev it up again. If I press the pedal down twice real fast, it will rev on the first press but do nothing on the second. I have a 2005 WK 5.7. I was trying to hear if I had an exhaust leak because I thought I heard something that sounded like it the other day I was driving it. Thank You!

Escape 03-27-2012 11:11 PM

Re: Is this normal?
 
There is a rev limiter in Park and Neutral (4K). Your probably hitting it.

It's a smart Jeep with an electronic TB and the Jeep knows it's not in drive, therefor it says no not gonna do it.

JDubz 03-28-2012 10:16 PM

Re: Is this normal?
 
Lol okay. Thank You! I guess I am not used to driving something this new yet. My other vehicles never did anything like that.

kennzz05 03-28-2012 10:26 PM

Re: Is this normal?
 
block off the end of the tailpipe while idleing and listen for leaks

JDubz 03-28-2012 11:09 PM

Re: Is this normal?
 
Quote:

Originally Posted by kennzz05 (Post 602874)
block off the end of the tailpipe while idleing and listen for leaks

Thank You, I will give that a try.


All times are GMT -5. The time now is 06:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community