Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Throttle Position Sensor going bad (http://www.jeepgarage.org/f203/throttle-position-sensor-going-bad-39924.html)

GrnBeltWarrior 03-28-2012 11:43 AM

Throttle Position Sensor going bad
 
Think I have a TPS going bad. Without using cruise control all seems normal. Using cruise between 40-55 mph the RPMs surge from 1600 to 2100 then drops down to 1600 then back up to 2100 til either I cancel the cruise or get it above 55mph.

Google and reading posts point me in that direction. Dealer wants $84 for their part. I'll probably get a NAPA or similar off brand for $40.

Anyone have any experience or thoughts?

cheapjeep 03-28-2012 12:30 PM

Re: Throttle Position Sensor going bad
 
You think it would do it with or without cruise but if you have a lot of miles on it I'd change the tps anyway because they're known for causing a lot of strange issues.

GrnBeltWarrior 03-28-2012 01:10 PM

Re: Throttle Position Sensor going bad
 
Quote:

Originally Posted by cheapjeep (Post 602384)
You think it would do it with or without cruise but if you have a lot of miles on it I'd change the tps anyway because they're known for causing a lot of strange issues.

That is exactly what I got from reading. Seems they don't crap out totally at once. Love them sensors boy.

01grand 03-28-2012 03:58 PM

Re: Throttle Position Sensor going bad
 
Quote:

Originally Posted by GrnBeltWarrior (Post 602421)
That is exactly what I got from reading. Seems they don't crap out totally at once. Love them sensors boy.

No, they don't just crap out, they make your jeep do all sorts of weird shtuff, like messing with cruise, screwing up tranny shift points, sometimes with others without check engine lights. (mine did all of this before I finally replaced it) Just replace the POS sensor, I got one at Advance Auto for $35 and its been fine for almost a year now. Takes about 20 min or less to replace with the right tools. 2 screws, 1 wire connector.

GrnBeltWarrior 03-28-2012 06:55 PM

Re: Throttle Position Sensor going bad
 
Well the one I got made it all kinds of worse. Threw P0123 (TPS) and good thing I didn't try to drive more than a block away, would not shift or hold a steady rpm.

Put the old one back on, cleared the code. Back to before. I'm thinking/hoping the BWD part might be DOA.

hummer recovery team 03-28-2012 07:53 PM

Re: Throttle Position Sensor going bad
 
Heres a link to the part

http://shop.advanceautoparts.com/web...R%7CGRPSENSAMS

01grand 03-28-2012 10:01 PM

Quote:

Originally Posted by GrnBeltWarrior (Post 602683)
Well the one I got made it all kinds of worse. Threw P0123 (TPS) and good thing I didn't try to drive more than a block away, would not shift or hold a steady rpm.

Put the old one back on, cleared the code. Back to before. I'm thinking/hoping the BWD part might be DOA.

Probably just a bad part, I've had good luck with BWD before. What you first described with the code is what mine started doing when I finally replaced it.

GrnBeltWarrior 03-30-2012 01:44 PM

Re: Throttle Position Sensor going bad
 
The problem appeared from no where and now its not doing it anymore.:(
I really hate goofy problems. Found out today my bilstein shocks will be in Wednesday so I guess it evens out?

01grand 03-30-2012 01:58 PM

Re: Throttle Position Sensor going bad
 
Quote:

Originally Posted by GrnBeltWarrior (Post 603955)
The problem appeared from no where and now its not doing it anymore.:(
I really hate goofy problems. Found out today my bilstein shocks will be in Wednesday so I guess it evens out?

YAY! Bilstein shocks are one of my favorite mods, along with the addco sways.

morganlovesjeep1995 04-02-2013 03:45 PM

Re: Throttle Position Sensor going bad
 
Do you think this could be my problem... Here is what my car is doing. It likes to drop rpms to 0 and shut off. Sometimes it'll crank right back up n sometimes it won't. Whenever it does it, the car sounds like it wants to crank. I've had my battery checked multiple times n that is not it. If you can help will you please email me at hayes_morgan1995@yahoo.com
Thank you soooo much!!!

Frango100 04-02-2013 04:50 PM

Re: Throttle Position Sensor going bad
 
Welcome to the garage.
This seems more as a crank or cam sensor going bad. Did you check for any fault code using the key dance? ( ignition switch off/on 3 times and leave it in on at the third time. The odometer will show a fault code, or "DONE"when all ok. Could eventually be a dirty idle air control motor plunjer and air canal. This needs a throttle body cleaning.


All times are GMT -5. The time now is 11:53 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community