Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Having problems with my headlights (http://www.jeepgarage.org/f181/having-problems-with-my-headlights-39958.html)

JDubz 03-28-2012 10:22 PM

Having problems with my headlights
 
My 05 5.7 WK is having problems with the passenger side headlight. I noticed that the passenger side headlight went out not too long after I bought it. When I went to go pull it out, it came back on. It is only the low beams, the highs and fogs work just fine. Its been about 3 weeks now and it went out again. This seems like I must have a problem in the wiring since the bulb seems to work just fine. Also, the previous owner put in silverstars for the low beams if that matters at all. I just want to get this fixed since I have to take it out of town for the weekend. Hopefully it is something simple...

2005JGC 03-28-2012 10:29 PM

Re: Having problems with my headlights
 
eh bulbs can fail this way, I would possibly suggest starting with new bulbs, very well could be your problem.

Actually, just swap your low beams side to side and see if the problem follows.

JDubz 03-28-2012 11:07 PM

Re: Having problems with my headlights
 
Sounds good. Thank you.

JMLoughrey 03-28-2012 11:20 PM

Re: Having problems with my headlights
 
also maybe a good idea to clean your contacts in the headlight connectors.

JDubz 03-29-2012 02:52 PM

Re: Having problems with my headlights
 
Okay so some bad news I think. I went to go switch the bulbs around to see if they were bad and here is what I found:

http://i1062.photobucket.com/albums/...329_142830.jpg

http://i1062.photobucket.com/albums/...329_142933.jpg

Does this mean I need to replace the wires? What would have caused this? The drivers side bulbs/connectors all looked good. I checked both the Highs/Lows and they all looked good as well. This is the passenger side low beam. Help!

JDubz 03-29-2012 02:53 PM

Re: Having problems with my headlights
 
Here is a picture of the low beam bulbs that were being used:

http://i1062.photobucket.com/albums/...329_143413.jpg

http://i1062.photobucket.com/albums/...329_142945.jpg

2005JGC 03-29-2012 03:06 PM

Re: Having problems with my headlights
 
this could have been caused by a poor connection, also possibly due to current demands from the aftermarket bulb...

you need something like this:

http://www.repairconnector.com/produ...ru-2005--.html

I would repair the harness and replace the bulbs with 35w bulbs.

JDubz 03-29-2012 03:15 PM

Re: Having problems with my headlights
 
What brand bulbs would you recommend?

JDubz 03-29-2012 03:16 PM

Re: Having problems with my headlights
 
Quote:

Originally Posted by 2005JGC (Post 603339)
this could have been caused by a poor connection, also possibly due to current demands from the aftermarket bulb...

you need something like this:

http://www.repairconnector.com/produ...ru-2005--.html

I would repair the harness and replace the bulbs with 35w bulbs.


And is this just a simple splice in connector or do they sell a complete wiring harness?

2005JGC 03-30-2012 02:11 AM

I have not worked with that website but I believe its just a splice in connector end, I would imagine you can pick one up from alocal auto parts store. Anything that is 35w would work for headlights.

Sent from my SCH-I500 using Tapatalk

JDubz 03-30-2012 08:38 AM

Re: Having problems with my headlights
 
Okay so I called oreilly's and they do carry them. Ill let you know how it goes. I should be okay without a soldering iron right?

nyc_medic 03-30-2012 08:46 AM

Re: Having problems with my headlights
 
Wow atleast you found out what was causing you the issue without wasting too much time. Good luck with the repair. I 2nd the 35w bulb, the 55w was probably too much.


All times are GMT -5. The time now is 03:53 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community